Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

force use of .nanny file

  • Loading branch information...
commit dc71eb2c17a09aa97fd4ad31951525ee22f43143 1 parent 0e28d31
@nathanmarz authored
Showing with 17 additions and 15 deletions.
  1. +14 −12 nanny.py
  2. +3 −3 setup.py
View
26 nanny.py
@@ -28,24 +28,26 @@
from optparse import OptionParser
-try:
- from _config.nannyconstants import *
-except ImportError:
- from ConfigParser import SafeConfigParser
- from os.path import expanduser, exists
-
- nanny_file = expanduser('~/.nanny')
- if not exists(nanny_file):
- raise OSError, "File does not exist %s" % nanny_file
-
- parser = SafeConfigParser()
- parser.read(expanduser('~/.nanny'))
+from ConfigParser import SafeConfigParser
+from os.path import expanduser, exists
import sys
import os
import subprocess
import shutil
+
+nanny_file = expanduser('~/.nanny')
+if not exists(nanny_file):
+ raise OSError, "File does not exist %s" % nanny_file
+
+parser = SafeConfigParser()
+parser.read(expanduser('~/.nanny'))
+
+REPOSITORY_HOST = parser.get("nanny", "REPOSITORY_HOST")
+REPOSITORY_USER = parser.get("nanny", "REPOSITORY_USER")
+REPOSITORY_PATH = parser.get("nanny", "REPOSITORY_PATH")
+
'''
TODO: should lock the repository
- should we just use svn or git as the repository?
View
6 setup.py
@@ -2,10 +2,10 @@
setup(
name='nanny',
- version='0.1.0', #Correct version?
+ version='0.1.1',
install_requires=['paramiko'],
entry_points={
- 'console_scripts' : ['nanny=nanny:main'],
+ 'console_scripts' : ['nanny=nanny:main']
},
- py_modules = ['nanny'],
+ py_modules = ['nanny']
)
Please sign in to comment.
Something went wrong with that request. Please try again.