Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Use a Regexp compatible with Ruby1.8. #36

Merged
merged 1 commit into from

2 participants

Cédric Boutillier Clifford Heath
Cédric Boutillier

[[:^space:]] is not a valid Regexp character class for Ruby1.8. This patch changes it to the equivalent [^[:space:]].
This would solve #32 issue with specs.

Cédric Boutillier boutil Update character_class_spec.rb
Use a Regexp compatible with Ruby1.8.
This would solve nathansobo#32.
c6fd111
Clifford Heath
Collaborator

Thankyou, but in future please direct pull requests to the project homepage (see https://rubygems.org/gems/treetop).

Clifford Heath cjheath merged commit 4c071be into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jun 19, 2013
  1. Cédric Boutillier

    Update character_class_spec.rb

    boutil authored
    Use a Regexp compatible with Ruby1.8.
    This would solve nathansobo#32.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  spec/compiler/character_class_spec.rb
2  spec/compiler/character_class_spec.rb
View
@@ -86,7 +86,7 @@ module ModFoo
end
describe "a character class with a negated POSIX bracket expression" do
- testing_expression "[[:^space:]]"
+ testing_expression "[^[:space:]]"
it "matches a character outside the negated class" do
parse('a').should_not be_nil
end
Something went wrong with that request. Please try again.