New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

BridJ: BridJ.addLibraryPath() method doesn't work if path contains non-ascii symbols (non-english) #276

Closed
AndreiSochirca opened this Issue Feb 29, 2012 · 4 comments

Comments

Projects
None yet
2 participants
@AndreiSochirca

AndreiSochirca commented Feb 29, 2012

Hi Olivier,

It seems if BridJ.addLibraryPath() parameter has non-english symbols then BridJ fails to load the library in this path.

Regards, Andrei.

@AndreiSochirca

This comment has been minimized.

AndreiSochirca commented Feb 29, 2012

BridJ correctly finds the native library in the specified path:
E:\тест\x264.dll
but it fails to load it with
BridJ: LoadLibrary error when loading E:\тест\x264.dll : The specified module could not be found.

Regards, Andrei.

@ochafik

This comment has been minimized.

Member

ochafik commented Feb 29, 2012

Hi Andrei,

Thanks for your report !
Working on a fix as I write,

Cheers

@ochafik

This comment has been minimized.

Member

ochafik commented Mar 1, 2012

Hi Andrei,

This should now be fixed in 0.7-SNAPSHOT, please let me know if you still experience issues...

Cheers

@ochafik ochafik closed this Mar 1, 2012

@AndreiSochirca

This comment has been minimized.

AndreiSochirca commented Mar 1, 2012

Hi Olivier,

It works. Thank you very much!!!

Regards, Andrei.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment