New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No device found on Intel OpenCL SDK win7 32bit #297

Closed
karolovbrat opened this Issue Apr 8, 2012 · 4 comments

Comments

Projects
None yet
2 participants
@karolovbrat

karolovbrat commented Apr 8, 2012

Hi,

I run into a following problem when running JavaCL on Windows 7 32 bit with Intel OpenCL SDK.

Exception in thread "main" java.lang.NullPointerException
at com.nativelibs4java.opencl.JavaCL.createBestContext(JavaCL.java:246)
at com.nativelibs4java.opencl.JavaCL.createBestContext(JavaCL.java:237)
...

After closer inspection I figured out the clGetDeviceIDs wrapper does not return any device what is rather strange as in C code (in VS2008 C++ Express) it works just fine and returns my Intel Core 2 Duo P8700.

Regards,

Jan

@ochafik

This comment has been minimized.

Show comment
Hide comment
@ochafik

ochafik Apr 11, 2012

Member

Hi @karolovbrat ,

Thanks a lot for your report !
I'll investigate asap.

Cheers

Member

ochafik commented Apr 11, 2012

Hi @karolovbrat ,

Thanks a lot for your report !
I'll investigate asap.

Cheers

ochafik added a commit that referenced this issue Apr 14, 2012

JavaCL: use CL_DEVICE_TYPE_ALL instead of OR-ing CL_DEVICE_TYPE_GPU a…
…nd CL_DEVICE_TYPE_CPU, because the latter pisses Intel OpenCL implementation off (issue #297)
@ochafik

This comment has been minimized.

Show comment
Hide comment
@ochafik

ochafik Apr 14, 2012

Member

Hi @karolovbrat ,

I've committed and deployed a fix (in new 1.0-SNAPSHOT), thanks for your patience.

Cheers

Member

ochafik commented Apr 14, 2012

Hi @karolovbrat ,

I've committed and deployed a fix (in new 1.0-SNAPSHOT), thanks for your patience.

Cheers

@karolovbrat

This comment has been minimized.

Show comment
Hide comment
@karolovbrat

karolovbrat Apr 14, 2012

Hi Olivier,

thanks a lot for the fix, now it works fine :)
Btw. good job with eliminating the issues I see that you managed to fix at least 20 of them in a pretty short time :)

Cheers

karolovbrat commented Apr 14, 2012

Hi Olivier,

thanks a lot for the fix, now it works fine :)
Btw. good job with eliminating the issues I see that you managed to fix at least 20 of them in a pretty short time :)

Cheers

@ochafik

This comment has been minimized.

Show comment
Hide comment
@ochafik

ochafik Apr 15, 2012

Member

Hi @karolovbrat ,

Thanks for your feedback !

I rarely get a full day of open-source programming like yesterday, so I wanted to make the most out of it ;-)

Cheers

Member

ochafik commented Apr 15, 2012

Hi @karolovbrat ,

Thanks for your feedback !

I rarely get a full day of open-source programming like yesterday, so I wanted to make the most out of it ;-)

Cheers

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment