Permalink
Browse files

restrict thin dependency to < 1.6

1.6 requires eventmachine 1.x, which fails to resolve
  • Loading branch information...
1 parent ba4b293 commit 53bd8c21ab452ef6eb6456d082a901c8564b3fb0 Alex Suraci and Maria Shaldibina committed Oct 11, 2013
Showing with 5 additions and 5 deletions.
  1. +1 −1 Gemfile
  2. +2 −2 Gemfile.lock
  3. +2 −2 nats.gemspec
View
@@ -3,7 +3,7 @@ source "http://rubygems.org"
gem 'eventmachine', '= 0.12.10'
gem 'daemons', '>= 1.1.5'
gem 'json_pure', '>= 1.7.3', :require => 'json'
-gem 'thin', '>= 1.4.1'
+gem 'thin', '>= 1.4.1', '< 1.6'
group :test do
gem 'rake'
View
@@ -5,7 +5,7 @@ PATH
daemons (>= 1.1.5)
eventmachine (= 0.12.10)
json_pure (>= 1.7.3)
- thin (>= 1.4.1)
+ thin (>= 1.4.1, < 1.6)
GEM
remote: http://rubygems.org/
@@ -41,4 +41,4 @@ DEPENDENCIES
nats!
rake
rspec (>= 2.11.0)
- thin (>= 1.4.1)
+ thin (>= 1.4.1, < 1.6)
View
@@ -19,7 +19,7 @@ spec = Gem::Specification.new do |s|
s.add_dependency('eventmachine', '= 0.12.10')
s.add_dependency('json_pure', '>= 1.7.3')
s.add_dependency('daemons', '>= 1.1.5')
- s.add_dependency('thin', '>= 1.4.1')
+ s.add_dependency('thin', '>= 1.4.1', '< 1.6')
s.require_paths = ['lib']
s.bindir = 'bin'
@@ -52,4 +52,4 @@ spec = Gem::Specification.new do |s|
lib/nats/server/connz.rb
]
-end
+end

0 comments on commit 53bd8c2

Please sign in to comment.