Permalink
Browse files

Lock EM to 0.12.10

  • Loading branch information...
1 parent 331a5b3 commit ac8bcd9643dd416067f5ef047b475ebeb15f02e6 @derekcollison derekcollison committed Sep 17, 2012
Showing with 4 additions and 5 deletions.
  1. +1 −2 Gemfile
  2. +2 −2 Gemfile.lock
  3. +1 −1 nats.gemspec
View
@@ -1,6 +1,6 @@
source "http://rubygems.org"
-gem 'eventmachine', '>= 0.12.10'
+gem 'eventmachine', '= 0.12.10'
gem 'daemons', '>= 1.1.5'
gem 'json_pure', '>= 1.7.3', :require => 'json'
gem 'thin', '>= 1.4.1'
@@ -10,4 +10,3 @@ group :test do
gem 'rspec', '>= 2.11.0'
gem 'nats', :path => '.'
end
-
View
@@ -3,7 +3,7 @@ PATH
specs:
nats (0.4.26)
daemons (>= 1.1.5)
- eventmachine (>= 0.12.10)
+ eventmachine (= 0.12.10)
json_pure (>= 1.7.3)
thin (>= 1.4.1)
@@ -36,7 +36,7 @@ PLATFORMS
DEPENDENCIES
daemons (>= 1.1.5)
- eventmachine (>= 0.12.10)
+ eventmachine (= 0.12.10)
json_pure (>= 1.7.3)
nats!
rake
View
@@ -16,7 +16,7 @@ spec = Gem::Specification.new do |s|
s.authors = ['Derek Collison']
s.email = ['derek.collison@gmail.com']
- s.add_dependency('eventmachine', '>= 0.12.10')
+ s.add_dependency('eventmachine', '= 0.12.10')
s.add_dependency('json_pure', '>= 1.7.3')
s.add_dependency('daemons', '>= 1.1.5')
s.add_dependency('thin', '>= 1.4.1')

4 comments on commit ac8bcd9

d replied Apr 4, 2013

Did we have a problem with EM greater than 0.12.10? Can we test that?

  • Jesse and Phan
Owner

derekcollison replied Apr 5, 2013

I've just tried implementing some asynchronous HTTP routines using em-http-request's EventMachine::HttpRequest, because the regular Net::HTTP is synchronous-only. I've run into a version conflict though because the em-http-request gem requires eventmachine >= 1.0.0, but NATS doesn't pass its tests on 1.0.0. So before I go off hacking my NATS gem or taking undue risk with versions, I wonder if there's any update. eventmachine is now up to 1.0.3; or has anyone come across a good alternative pattern for async http with NATS other than em-http-request?
Thanks as always for making NATS available.

Owner

derekcollison replied Apr 26, 2013

I will take a look to see if I can make the cluster branch work with 1.0.

Please sign in to comment.