Skip to content
This repository has been archived by the owner on Oct 19, 2022. It is now read-only.

navarr/magento2-supported-versions

master
Switch branches/tags

Name already in use

A tag already exists with the provided branch name. Many Git commands accept both tag and branch names, so creating this branch may cause unexpected behavior. Are you sure you want to create this branch?
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 

Magento EOL

EOQ: End of Quality Fixes.
EOL: End of Security Fixes/End of Software Support

Magento Minor Version Release EOQ EOL
2.0 November 2015 March 2018 March 2018
2.1 June 2016 June 2019 July 1, 2019
2.2 September 2017 December 2019 December 2019
2.3 November 2018 July 2021 April 28, 2022
2.4 July 2020

Notes:

  1. Information taken regularly from the Magento Software Lifecycle Policy document

Supported Software

PHP

Magento Minor Version PHP 5.5 PHP 5.6 PHP 7.0 PHP 7.1 PHP 7.2 PHP 7.3 PHP 7.4 PHP 8.0 PHP 8.1
2.0
2.1 [1] 2.1.16+
2.2 [2] 2.2.10+
2.3 [3] Until 2.3.6-p1 2.3.3 - 2.3.6[4] 2.3.7+
2.4 Until 2.4.1[4] Until 2.4.55 5 2.4.4+

Notes:

  1. Only 7.0.2 and ~7.0.6 for 2.1.0-2.1.1. Starting with 2.1.2 that was expanded to include 7.0.4.
  2. 7.0.2, 7.0.4, and ~7.0.6 for 2.2.0-2.2.4. Starting with 2.2.5 7.0 support was limited to ~7.0.13
  3. Supports ~7.1.3
  4. The composer.json in 2.3.7, 2.4.1, and 2.4.2 appears to support 7.3, however the System Requirements does not list it as a supported version. This likely means it can work, but you'll be on your own.
  5. Adobe has announced they're removing 7.3 in 2.4.4. This likely means that 2.4.4 will be semi-compatible with 7.4 and 8.0, though it is targeting 8.1.

Composer

Magento Minor Version 1 2
2.0
2.1
2.2
2.3 Until 2.3.7[1] 2.3.7+
2.4 Until 2.4.2[1] 2.4.2+

Notes:

  1. Composer 1 still works with Magento 2.3.7 and 2.4.2, but is no longer supported.

Elasticsearch

Magento Minor Version ES 1.x ES 2.x ES 5.x ES 6.x ES 7.4.x ES 7.6.x ES 7.9.x ES 7.10.x
2.1 1 2 2.1.13
2.2 Until 2.2.84 2.2.8+ 2.2.8+
2.3 Until 2.3.5 Until 2.3.5 2.3.5+ 2.3.7+
2.4 2.4.2+6 2.4.0-2.4.15 2.4.2+ 2.4.4+

Notes:

  1. Versions 2.1.1-2.1.2 declare support for all 1.x, but all other 2.1.x versions only declare support for 1.7
  2. Version 2.1.0 only declares support for 2.0 and 2.1. All other lines claim support for 2.x
  3. Version 2.1.1 is the only version in the 2.1.x line to declare support for ES 5, and then only for 5.0
  4. 2.2.0-2.2.7 declare support for ES 1.7
  5. 2.4.0 specifically declares support for ES 7.6.x
  6. 2.4.2 states "Magento 2.4.x remains compatible with Elasticsearch 7.4.x" despite compatibility not being declared at any point

Opensearch

Magento Minor Version OS 1.x
2.4 2.4.4+

RabbitMQ

Magento Minor Version 3.5 3.7 3.8
2.0
2.1
2.2
2.3 Until 2.3.5
2.4

Redis

Magento Minor Version 2.4 3.0 3.2 4.x 5.x 6.0
2.0
2.1 2.1.17+ 2.1.17+
2.2
2.3 Until 2.3.6 Until 2.3.6 Until 2.3.6 2.3.1 - 2.3.5 2.3.1 - 2.3.6 2.3.7+
2.4 2.4.0 - 2.4.1 2.4.2+

Varnish

Magento Minor Version 3.5 4.x 5.x 6.x
2.0
2.1
2.2
2.3 1 2
2.4 3

Notes:

  1. Magento declares support for 5.2+
  2. Magento declares support for 6.2+, 6.5.1 explicitly supported with 2.3.7
  3. Tested with 6.3.1. Magento 2.4.2 tested with 6.4

Databases

MySQL

Magento Minor Version 5.6 5.7 8.0
2.0
2.1 2.1.2+
2.2
2.3 1
2.4 1

Notes:

  1. Magento is also compatible with, but has not been tested and is not recommended

MariaDB

Magento Minor Version 10.0 10.1 10.2 10.3 10.4 10.5
2.0
2.1 2.1.2+
2.2 1 1 1
2.3 1 1 1 1 1
2.4 2 2 2

Notes:

  1. Magento only uses MySQL features compatible with MariaDB. MariaDB may not be compatible with all MySQL features, however, so be sure to research compatibility issues before using a feature in your Magento module.
  2. Magento is also compatible, but has not been tested and is not recommended

About

Versions of software supported by Magento 2

Topics

Resources

License

Stars

Watchers

Forks

Releases

No releases published

Sponsor this project

 

Packages

No packages published

Contributors 4

  •  
  •  
  •  
  •