Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Statically link CURL #473

Closed
aguycalled opened this issue May 8, 2019 · 7 comments

Comments

Projects
None yet
2 participants
@aguycalled
Copy link
Member

commented May 8, 2019

CURL is currently dynamically linked, making libcurl a dependency in unix systems.

@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 8, 2019

ACK, will work on this after I get symbols check fixed

@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 8, 2019

Comparison of links in bitcoin-core:

ldd bitcoin-0.17.1/bin/bitcoind                                                            
	linux-vdso.so.1 (0x00007f23f9f53000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f23f8e6f000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f23f8c67000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f23f88c9000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f23f86b1000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f23f82c0000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f23f9d2e000)

navcoin-core:

ldd navcoin-4.6.0/bin/navcoind                                                                                                                                                                1 
	linux-vdso.so.1 (0x00007ffc131a0000)
	libcurl.so.4 => /usr/lib/x86_64-linux-gnu/libcurl.so.4 (0x00007f733dae0000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f733d8c1000)
	libanl.so.1 => /lib/x86_64-linux-gnu/libanl.so.1 (0x00007f733d6bd000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f733d4b5000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f733d117000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f733ceff000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f733cb0e000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f733ec1b000)
	libnghttp2.so.14 => /usr/lib/x86_64-linux-gnu/libnghttp2.so.14 (0x00007f733c8e9000)
	libidn2.so.0 => /usr/lib/x86_64-linux-gnu/libidn2.so.0 (0x00007f733c6cc000)
	librtmp.so.1 => /usr/lib/x86_64-linux-gnu/librtmp.so.1 (0x00007f733c4b0000)
	libpsl.so.5 => /usr/lib/x86_64-linux-gnu/libpsl.so.5 (0x00007f733c2a2000)
	libssl.so.1.1 => /usr/lib/x86_64-linux-gnu/libssl.so.1.1 (0x00007f733c038000)
	libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007f733bbc0000)
	libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f733b975000)
	libldap_r-2.4.so.2 => /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2 (0x00007f733b723000)
	liblber-2.4.so.2 => /usr/lib/x86_64-linux-gnu/liblber-2.4.so.2 (0x00007f733b515000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f733b2f8000)
	libunistring.so.2 => /usr/lib/x86_64-linux-gnu/libunistring.so.2 (0x00007f733af7a000)
	libgnutls.so.30 => /usr/lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007f733ac15000)
	libhogweed.so.4 => /usr/lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007f733a9e1000)
	libnettle.so.6 => /usr/lib/x86_64-linux-gnu/libnettle.so.6 (0x00007f733a7ab000)
	libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f733a52a000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f733a326000)
	libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f733a050000)
	libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f7339e1e000)
	libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f7339c1a000)
	libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f7339a0f000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f73397f4000)
	libsasl2.so.2 => /usr/lib/x86_64-linux-gnu/libsasl2.so.2 (0x00007f73395d9000)
	libgssapi.so.3 => /usr/lib/x86_64-linux-gnu/libgssapi.so.3 (0x00007f7339398000)
	libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f7339069000)
	libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f7338e56000)
	libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f7338c52000)
	libheimntlm.so.0 => /usr/lib/x86_64-linux-gnu/libheimntlm.so.0 (0x00007f7338a49000)
	libkrb5.so.26 => /usr/lib/x86_64-linux-gnu/libkrb5.so.26 (0x00007f73387bc000)
	libasn1.so.8 => /usr/lib/x86_64-linux-gnu/libasn1.so.8 (0x00007f733851a000)
	libhcrypto.so.4 => /usr/lib/x86_64-linux-gnu/libhcrypto.so.4 (0x00007f73382e4000)
	libroken.so.18 => /usr/lib/x86_64-linux-gnu/libroken.so.18 (0x00007f73380ce000)
	libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f7337ec6000)
	libwind.so.0 => /usr/lib/x86_64-linux-gnu/libwind.so.0 (0x00007f7337c9d000)
	libheimbase.so.1 => /usr/lib/x86_64-linux-gnu/libheimbase.so.1 (0x00007f7337a8e000)
	libhx509.so.5 => /usr/lib/x86_64-linux-gnu/libhx509.so.5 (0x00007f7337844000)
	libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f733753b000)
	libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f7337303000)
@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 8, 2019

Seems we have way more dependencies than just libcurl.

@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 8, 2019

Seems we have way more dependencies than just libcurl.

Hmm, seems not to be the case, I guess the last build 4.6.0 was built without --disabled-shared configure param

@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 9, 2019

I was able to do a build with these results:

ldd src/navcoind                                                                                                                                   +1   patch-5 
        linux-vdso.so.1 (0x00007ffe743ce000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f22cf6bb000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f22cf49c000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f22cf113000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f22ced75000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f22ceb5d000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f22ce76c000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f22d07f2000)

@mxaddict

This comment has been minimized.

Copy link
Contributor

commented May 9, 2019

Changes for this issue are pushed to #461

@aguycalled

This comment has been minimized.

Copy link
Member Author

commented May 27, 2019

Paid f2a337c89141c835791bf10b2a1d455d1d7a4a0203d1e66e6fe6b9e4dabe9077

@aguycalled aguycalled closed this May 27, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.