New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Notification icon missing again on Android Oreo #640

Open
mvglasow opened this Issue Aug 5, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@mvglasow
Contributor

mvglasow commented Aug 5, 2018

Steps to reproduce

  1. Install a recent build of Navit on Android Nougat (7.x).
  2. Start Navit and observe the notification icon.
  3. Install the same build on Android Oreo (8.x), or upgrade the OS on the device.
  4. Start Navit again and observe the notification icon.

Expected behavior

Notification icon appears while Navit is running, regardless of OS version

Actual behavior

Notification icon appears on Android 7 but not on Android 8.

Versions tested

Navit d421350 (actually a branch of it, with no changes regarding the notification), on LineageOS 14.1 and 15.1 respectively.

@mvglasow mvglasow changed the title from Notification icon missign again on Android Oreo to Notification icon missing again on Android Oreo Aug 5, 2018

@jkoan

This comment has been minimized.

Member

jkoan commented Aug 12, 2018

Hi @mvglasow
I can reproduce the same issue on my Oneplus 3T with Android 8.0.0 (Original Firmware -> OxygenOS)
I will look into it again soon.

@jkoan

This comment has been minimized.

Member

jkoan commented Aug 12, 2018

It's probably due to the new channels.
This post has a good description around this: https://stackoverflow.com/a/43093261

So we probably only need to change things slightly

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment