Cave (Paludis Client) No ${ARCH} Variable #8

Closed
eternal-lc opened this Issue Nov 4, 2011 · 1 comment

Projects

None yet

2 participants

@eternal-lc

Not able to download amdstream since the ${ARCH} doesn't exist (or doesn't match amd64 or x86).

Result in:
"Checking 'AMD-APP-SDK-v2.5-lnx.tgz'... not in Manifest"

Just need to find a way of selecting the architecture.

Dirty way for my own architecture:

if [[ "${ARCH}" == "amd64" ]]; then

_arch="x86_64"
_other_arch="x86"
_bits="64"

elif [[ "${ARCH}" == "x86" ]]; then

_arch="x86"

_other_arch="x86_64"

_bits="32"

fi

Owner

Could you try commit id 08c75ca from "issue8" branch? It should fix this I think...

@nbigaouette nbigaouette closed this Nov 8, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment