Skip to content
NodeJS module for ElasticSearch.
JavaScript
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib
tests
.gitignore
README.md
index.js
package.json

README.md

node-elasticsearch

This is a module around the REST API for http://www.elasticsearch.org/ built for NodeJS.

Details

This works with node 0.4.x and with 0.2.x. I needed it for both and so wrote an http compatability layer.

Usage

 var lib = require('elasticsearch'), sys = require('sys'); //replace sys with util if you're on node 0.4.x
 lib.createClient(function(client) {
     client.query({query: {field: {field1: 'hai'}}}, function(err, results) {
         console.log(sys.inspect(results, true, 10));
     });
 });

API

Will go here when I'm ready to post it.

Requirements

  • NodeJS
  • Elastic Search
  • The need for search

License

MIT

Something went wrong with that request. Please try again.