Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fixed tests

  • Loading branch information...
commit 3e6d0558291776475a27029e4cf07cc2c851f3ab 1 parent 43f47aa
@ndbroadbent authored
View
2  .travis.yml
@@ -2,8 +2,8 @@ language: ruby
script: bundle install; bundle exec rake test
rvm:
- 1.8.7
+ - 1.9.2
- 1.9.3
- - ruby-head
gemfile:
- gemfiles/Gemfile-rails.3.2.0
- gemfiles/Gemfile-rails.3.2.x
View
1  Gemfile
@@ -8,7 +8,6 @@ gem "jquery-rails"
gem "uglifier", :require => false
gem "mocha", :require => false
-gem "minitest", '~> 3.5.0', :platform => :mri_18
unless ENV['CI']
gem "debugger", :platform => :mri_19
View
1  Gemfile-rails-3.2.0
@@ -8,4 +8,3 @@ gem "jquery-rails"
gem "uglifier", :require => false
gem "mocha", :require => false
-gem "minitest", :platform => :mri_18
View
1  Gemfile-rails-3.2.x
@@ -8,4 +8,3 @@ gem "jquery-rails"
gem "uglifier", :require => false
gem "mocha", :require => false
-gem "minitest", '~> 2.12', :platform => :mri_18
View
11 test/abstract_unit.rb
@@ -3,8 +3,15 @@
require 'turbo-sprockets-rails3'
require 'fileutils'
-require 'minitest/unit'
-require 'minitest/autorun'
+
+# Require minitest for 1.9 and test/unit for 1.8
+# 'active_support/test_case' supports both.
+begin
+ require 'minitest/autorun'
+rescue LoadError
+ require 'test/unit'
+end
+
require 'active_support/test_case'
require 'rails/generators'
require "active_support/testing/isolation"
Please sign in to comment.
Something went wrong with that request. Please try again.