Permalink
Browse files

Minor fixes. Bump to 0.1.3

  • Loading branch information...
1 parent bf9fb1d commit 44d6716f802f3a128d169610a2e6fce0440b8d44 @javan javan committed Feb 17, 2009
Showing with 20 additions and 18 deletions.
  1. +3 −1 CHANGELOG.rdoc
  2. +1 −1 README.rdoc
  3. +3 −6 Rakefile
  4. +3 −1 bin/whenever
  5. +2 −2 lib/version.rb
  6. +1 −0 lib/whenever.rb
  7. +7 −7 whenever.gemspec
View
4 CHANGELOG.rdoc
@@ -1,4 +1,4 @@
-== 0.1.2 / February 16th, 2009
+== 0.1.3 / February 16th, 2009
* Added 'rake' helper for defining scheduled rake tasks. [Javan Makhmali]
@@ -8,6 +8,8 @@
* Got rid of already initialized constant warning. [Javan Makhmali]
+* Requiring specific gem versions: Chronic >=0.2.3 and activesupport >= 1.3.0 [Javan Makhmali]
+
== 0.1.0 / February 15th, 2009
View
2 README.rdoc
@@ -14,7 +14,7 @@ In a Rails (2.1 or greater) application:
in your "config/environment.rb" file:
Rails::Initializer.run do |config|
- config.gem 'javan-whenever', :lib => false, :version => '>= 0.1.2' :source => 'http://gems.github.com'
+ config.gem 'javan-whenever', :lib => false, :version => '>= 0.1.3' :source => 'http://gems.github.com'
end
To install this gem (and all other missing gem dependencies), run rake gems:install (use sudo if necessary).
View
9 Rakefile
@@ -1,16 +1,13 @@
-require './lib/version'
-
require 'rubygems'
require 'rake'
require 'echoe'
-WHENEVER_VERSION = Whenever::VERSION::STRING.dup
+require File.expand_path(File.dirname(__FILE__) + "/lib/version")
-Echoe.new('whenever', WHENEVER_VERSION) do |p|
- p.changelog = "CHANGELOG.rdoc"
+Echoe.new('whenever', Whenever::VERSION::STRING) do |p|
p.description = "Provides clean ruby syntax for defining messy cron jobs and running them Whenever."
p.url = "http://github.com/javan/whenever"
p.author = "Javan Makhmali"
p.email = "javan@javan.us"
- p.dependencies = ["chronic", "activesupport"]
+ p.dependencies = ["chronic >=0.2.3", "activesupport >=1.3.0"]
end
View
4 bin/whenever
@@ -4,12 +4,14 @@ require 'rake'
require 'optparse'
require 'whenever'
+require File.expand_path(File.dirname(__FILE__) + "/../lib/version")
+
task = "whenever:output_cron"
OptionParser.new do |opts|
opts.banner = "Usage: whenever [options]"
opts.on('-c', '--write-crontab') { task = "whenever:write_cron" }
- opts.on('-v', '--version') { puts "Whenever v#{WHENEVER_VERSION}"; exit }
+ opts.on('-v', '--version') { puts "Whenever v#{Whenever::VERSION::STRING}"; exit }
end.parse!
Rake::Task[task].invoke
View
4 lib/version.rb
@@ -2,8 +2,8 @@ module Whenever
module VERSION #:nodoc:
MAJOR = 0
MINOR = 1
- TINY = 2
+ TINY = 3
STRING = [MAJOR, MINOR, TINY].join('.')
end
-end
+end unless defined?(Whenever::VERSION)
View
1 lib/whenever.rb
@@ -21,6 +21,7 @@
require 'chronic'
require 'base'
+require 'version'
require 'job_list'
require 'job_types/default'
require 'job_types/rake_task'
View
14 whenever.gemspec
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{whenever}
- s.version = "0.1.2"
+ s.version = "0.1.3"
s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
s.authors = ["Javan Makhmali"]
@@ -26,14 +26,14 @@ Gem::Specification.new do |s|
s.specification_version = 2
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<chronic>, [">= 0"])
- s.add_runtime_dependency(%q<activesupport>, [">= 0"])
+ s.add_runtime_dependency(%q<chronic>, [">= 0.2.3"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 1.3.0"])
else
- s.add_dependency(%q<chronic>, [">= 0"])
- s.add_dependency(%q<activesupport>, [">= 0"])
+ s.add_dependency(%q<chronic>, [">= 0.2.3"])
+ s.add_dependency(%q<activesupport>, [">= 1.3.0"])
end
else
- s.add_dependency(%q<chronic>, [">= 0"])
- s.add_dependency(%q<activesupport>, [">= 0"])
+ s.add_dependency(%q<chronic>, [">= 0.2.3"])
+ s.add_dependency(%q<activesupport>, [">= 1.3.0"])
end
end

0 comments on commit 44d6716

Please sign in to comment.