Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

ooc highlighting for VIM

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 ftdetect
Octocat-spinner-32 ftplugin
Octocat-spinner-32 indent
Octocat-spinner-32 spec
Octocat-spinner-32 syntax
Octocat-spinner-32 syntax_checkers
Octocat-spinner-32 .travis.yml
Octocat-spinner-32 Gemfile
Octocat-spinner-32 Gemfile.lock
Octocat-spinner-32 README.md
Octocat-spinner-32 Rakefile
README.md

Build Status

ooc.vim

This is the official vim plug-in for ooc language support.

It provides:

  • Syntax highlighting
  • Indentation support
  • A syntastic plug-in for use with sam
  • :make command support (launches rock -v)

Install instructions

Vundle is a very neat tool to manage your vim plugins, and is the recommended way to get ooc.vim and keep it up-to-date.

Add this to your ~/.vimrc:

Bundle 'nddrylliog/ooc.vim'

Then restart vim, run :BundleInstall, and you're set!

Installing ooc.vim with pathogen should be as easy as cloning it in ~/.vim/bundle

Syntastic

To use the syntastic plug-in, first you have to install syntastic itself.

For now, the dependencies are as follow:

  • rock 0.9.9 or greater, in your $PATH
  • sam 0.10.1 or greater, in your $PATH

This plug-in uses the sam check command if the dependencies above are met, to check whether there are errors in an .ooc file. It will only work for .ooc files that are part of a project that has a .use file, not for standalone ooc files.

Checking with rock can be slow at times, especially within large projects. There are two solutions to that.

One can change the checking mode using the g:syntastic_sam_mode option. To only do syntax checking instead of a full source check, do:

let g:syntastic_sam_mode = 'syntax'

The valid values for g:syntastic_sam_mode are syntax, check, and codegen (from fastest to most thorough).

Something went wrong with that request. Please try again.