Permalink
Browse files

In Saxon 9.6, the HE processor will run (some) 3.0 stylesheets

  • Loading branch information...
ndw committed Feb 4, 2015
1 parent 736c9ce commit 8ec94323fca70e558f09d5223a302c78885d5114
Showing with 0 additions and 4 deletions.
  1. +0 −4 src/com/xmlcalabash/library/XSLT.java
@@ -145,10 +145,6 @@ public void run() throws SaxonApiException {
version = getOption(_version).getString();
}
- if ("3.0".equals(version) && Configuration.softwareEdition.toLowerCase().equals("he")) {
- throw XProcException.stepError(38, "XSLT version '" + version + "' is not supported (Saxon PE or EE processor required).");
- }
-
// We used to check if the XSLT version was supported, but I've removed that check.
// If it's not supported by Saxon, we'll get an error from Saxon. Otherwise, we'll
// get the results we get.

0 comments on commit 8ec9432

Please sign in to comment.