Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Initializing an embedded XProc processor fails to find steps on classpath #208

Closed
ndw opened this issue May 14, 2015 · 1 comment
Closed

Initializing an embedded XProc processor fails to find steps on classpath #208

ndw opened this issue May 14, 2015 · 1 comment

Comments

@ndw
Copy link
Owner

@ndw ndw commented May 14, 2015

Florent reports:

I am adapting some code to Calabash 1.1.1.  I use
XProcRuntime.load() to compile a pipeline into an XPipeline object, on
which I call run().  As I was doing with 1.0.0.  But then, it throws
an XProcException wih the following message:

      Misconfigured. No 'class' in configuration for p:identity

Any idea what that could be?

A bug? :-)

ndw added a commit that referenced this issue May 14, 2015
…by moving the property changes to apply only to processors constructed by XML Calabash
ndw added a commit that referenced this issue May 14, 2015
…by moving the property changes to apply only to processors constructed by XML Calabash
@ndw
Copy link
Owner Author

@ndw ndw commented May 23, 2015

Fixed in 1.1.2.

@ndw ndw closed this May 23, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.