Permalink
Browse files

changes stuff to be spree 1.2 compatibile [ci skip]

still work in progress
  • Loading branch information...
1 parent f0f1113 commit e61d1df1758180741bebf3bd3a7218a73d2e6d89 @kennyadsl kennyadsl committed Dec 11, 2012
Showing with 135 additions and 105 deletions.
  1. +1 −0 .gitignore
  2. +107 −80 Gemfile.lock
  3. +1 −1 Rakefile
  4. +2 −2 lib/spree_subscriptions.rb
  5. +10 −10 spec/models/spree/subscription_spec.rb
  6. +9 −9 spec/support/order_helpers.rb
  7. +5 −3 spree_subscriptions.gemspec
View
@@ -7,4 +7,5 @@
tmp
nbproject
*.swp
+Gemfile.lock
spec/dummy
View
@@ -4,64 +4,64 @@ PATH
spree_subscriptions (1.1.1)
prawn (~> 0.12.0)
prawn-labels (~> 0.11.3)
- spree_auth (~> 1.1.2)
- spree_core (~> 1.1.2)
+ spree_auth_devise (~> 1.0.1)
+ spree_core (~> 1.2.2)
GEM
remote: http://rubygems.org/
specs:
- Ascii85 (1.0.1)
- actionmailer (3.2.7)
- actionpack (= 3.2.7)
+ Ascii85 (1.0.2)
+ actionmailer (3.2.9)
+ actionpack (= 3.2.9)
mail (~> 2.4.4)
- actionpack (3.2.7)
- activemodel (= 3.2.7)
- activesupport (= 3.2.7)
+ actionpack (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
rack (~> 1.4.0)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.3)
- active_utils (1.0.3)
+ sprockets (~> 2.2.1)
+ active_utils (1.0.5)
activesupport (>= 2.3.11)
i18n
- activemerchant (1.20.4)
+ activemerchant (1.28.0)
active_utils (>= 1.0.2)
activesupport (>= 2.3.11)
- braintree (>= 2.0.0)
builder (>= 2.0.0)
i18n
json (>= 1.5.1)
- money (<= 3.7.1)
- activemodel (3.2.7)
- activesupport (= 3.2.7)
+ money
+ nokogiri
+ activemodel (3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
- activerecord (3.2.7)
- activemodel (= 3.2.7)
- activesupport (= 3.2.7)
+ activerecord (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.7)
- activemodel (= 3.2.7)
- activesupport (= 3.2.7)
- activesupport (3.2.7)
+ activeresource (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
+ activesupport (3.2.9)
i18n (~> 0.6)
multi_json (~> 1.0)
acts_as_list (0.1.4)
- addressable (2.2.8)
+ addressable (2.3.2)
archive-tar-minitar (0.5.2)
arel (3.0.2)
+ awesome_nested_set (2.1.4)
+ activerecord (>= 3.0.0)
aws-sdk (1.3.9)
httparty (~> 0.7)
json (~> 1.4)
nokogiri (>= 1.4.4)
uuidtools (~> 2.1)
bcrypt-ruby (3.0.1)
- braintree (2.16.0)
- builder (>= 2.0.0)
- builder (3.0.0)
+ builder (3.0.4)
cancan (1.6.7)
capybara (1.0.1)
mime-types (>= 1.16)
@@ -70,9 +70,16 @@ GEM
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.3.2)
- ffi (~> 1.0.6)
- cocaine (0.2.1)
+ childprocess (0.3.6)
+ ffi (~> 1.0, >= 1.0.6)
+ cocaine (0.4.2)
+ coffee-rails (3.2.2)
+ coffee-script (>= 2.2.0)
+ railties (~> 3.2.0)
+ coffee-script (2.2.0)
+ coffee-script-source
+ execjs
+ coffee-script-source (1.4.0)
columnize (0.3.6)
deface (0.9.1)
nokogiri (~> 1.5.0)
@@ -84,50 +91,53 @@ GEM
warden (~> 1.1.1)
diff-lcs (1.1.3)
erubis (2.7.0)
+ execjs (1.4.0)
+ multi_json (~> 1.0)
factory_girl (3.5.0)
activesupport (>= 3.0.0)
ffaker (1.12.1)
- ffi (1.0.11)
+ ffi (1.2.0)
+ hashery (2.1.0)
highline (1.6.11)
hike (1.2.1)
- httparty (0.8.3)
+ httparty (0.9.0)
multi_json (~> 1.0)
multi_xml
- i18n (0.6.0)
+ i18n (0.6.1)
journey (1.0.4)
- jquery-rails (2.0.2)
- railties (>= 3.2.0, < 5.0)
- thor (~> 0.14)
- json (1.7.4)
+ jquery-rails (2.1.4)
+ railties (>= 3.0, < 5.0)
+ thor (>= 0.14, < 2.0)
+ json (1.7.5)
kaminari (0.13.0)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
railties (>= 3.0.0)
- libwebsocket (0.1.3)
+ libwebsocket (0.1.7.1)
addressable
+ websocket
linecache19 (0.5.12)
ruby_core_source (>= 0.1.4)
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.18)
- money (3.7.1)
+ mime-types (1.19)
+ money (5.0.0)
i18n (~> 0.4)
- multi_json (1.3.6)
+ json
+ multi_json (1.5.0)
multi_xml (0.5.1)
- nested_set (1.7.0)
- activerecord (>= 3.0.0)
- railties (>= 3.0.0)
- nokogiri (1.5.2)
+ nokogiri (1.5.5)
orm_adapter (0.0.7)
- paperclip (2.7.0)
+ paperclip (2.8.0)
activerecord (>= 2.3.0)
activesupport (>= 2.3.2)
cocaine (>= 0.0.2)
mime-types
- pdf-reader (1.1.1)
+ pdf-reader (1.2.0)
Ascii85 (~> 1.0.0)
+ hashery (~> 2.0)
ruby-rc4
polyamorous (0.5.0)
activerecord (~> 3.0)
@@ -137,30 +147,33 @@ GEM
ttfunk (~> 1.0.2)
prawn-labels (0.11.3.0)
prawn (>= 0.12.0)
+ rabl (0.7.2)
+ activesupport (>= 2.3.14)
+ multi_json (~> 1.0)
rack (1.4.1)
rack-cache (1.2)
rack (>= 0.4)
rack-ssl (1.3.2)
rack
- rack-test (0.6.1)
+ rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.7)
- actionmailer (= 3.2.7)
- actionpack (= 3.2.7)
- activerecord (= 3.2.7)
- activeresource (= 3.2.7)
- activesupport (= 3.2.7)
+ rails (3.2.9)
+ actionmailer (= 3.2.9)
+ actionpack (= 3.2.9)
+ activerecord (= 3.2.9)
+ activeresource (= 3.2.9)
+ activesupport (= 3.2.9)
bundler (~> 1.0)
- railties (= 3.2.7)
- railties (3.2.7)
- actionpack (= 3.2.7)
- activesupport (= 3.2.7)
+ railties (= 3.2.9)
+ railties (3.2.9)
+ actionpack (= 3.2.9)
+ activesupport (= 3.2.9)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
- rake (0.9.2.2)
- ransack (0.6.0)
+ rake (10.0.2)
+ ransack (0.7.0)
actionpack (~> 3.0)
activerecord (~> 3.0)
polyamorous (~> 0.5.0)
@@ -171,10 +184,10 @@ GEM
rspec-expectations (~> 2.11.0)
rspec-mocks (~> 2.11.0)
rspec-core (2.11.1)
- rspec-expectations (2.11.2)
+ rspec-expectations (2.11.3)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.11.1)
- rspec-rails (2.11.0)
+ rspec-mocks (2.11.3)
+ rspec-rails (2.11.4)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
@@ -190,49 +203,61 @@ GEM
ruby-rc4 (0.1.5)
ruby_core_source (0.1.5)
archive-tar-minitar (>= 0.5.2)
- rubyzip (0.9.8)
- selenium-webdriver (2.22.0)
+ rubyzip (0.9.9)
+ sass (3.2.3)
+ sass-rails (3.2.5)
+ railties (~> 3.2.0)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ select2-rails (3.2.1)
+ thor (~> 0.14)
+ selenium-webdriver (2.27.1)
childprocess (>= 0.2.5)
- ffi (~> 1.0)
libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
- spree_auth (1.1.3)
+ spree_auth_devise (1.0.1)
cancan (= 1.6.7)
- devise (~> 2.0.0)
- spree_core (= 1.1.3)
- spree_core (1.1.3)
- activemerchant (= 1.20.4)
+ devise (~> 2.0.4)
+ spree_core
+ spree_core (1.2.2)
+ activemerchant (= 1.28.0)
acts_as_list (= 0.1.4)
+ awesome_nested_set (= 2.1.4)
aws-sdk (~> 1.3.4)
+ cancan (= 1.6.7)
deface (>= 0.9.0)
ffaker (~> 1.12.0)
highline (= 1.6.11)
- jquery-rails (~> 2.0.0)
- kaminari (>= 0.13.0)
- nested_set (= 1.7.0)
- paperclip (~> 2.7)
- rails (~> 3.2.6)
- ransack (~> 0.6.0)
+ jquery-rails (~> 2.0)
+ kaminari (= 0.13.0)
+ money (= 5.0.0)
+ paperclip (~> 2.8)
+ rabl (= 0.7.2)
+ rails (~> 3.2.9)
+ ransack (~> 0.7.0)
+ select2-rails (~> 3.0)
state_machine (= 1.1.2)
stringex (~> 1.3.2)
- sprockets (2.1.3)
+ sprockets (2.2.2)
hike (~> 1.2)
+ multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.6)
state_machine (1.1.2)
stringex (1.3.3)
- thor (0.15.4)
+ thor (0.16.0)
tilt (1.3.3)
- treetop (1.4.10)
+ treetop (1.4.12)
polyglot
polyglot (>= 0.3.1)
ttfunk (1.0.3)
- tzinfo (0.3.33)
+ tzinfo (0.3.35)
uuidtools (2.1.3)
warden (1.1.1)
rack (>= 1.0)
+ websocket (1.0.4)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -241,9 +266,11 @@ PLATFORMS
DEPENDENCIES
capybara (= 1.0.1)
+ coffee-rails
factory_girl (~> 3.5.0)
ffaker
rspec-rails (~> 2.11.0)
ruby-debug19
+ sass-rails
spree_subscriptions!
sqlite3
View
@@ -25,5 +25,5 @@ end
desc 'Generates a dummy app for testing'
task :test_app do
ENV['LIB_NAME'] = 'spree_subscriptions'
- Rake::Task['common:test_app'].invoke
+ Rake::Task['common:test_app'].invoke "Spree::User"
end
@@ -1,5 +1,5 @@
require 'spree_core'
-require 'spree_auth'
+require 'spree_auth_devise'
require 'spree_subscriptions/engine'
require 'spree_subscriptions/validators/subscription'
-require 'prawn/labels'
+require 'prawn/labels'
Oops, something went wrong.

0 comments on commit e61d1df

Please sign in to comment.