New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Issues with display of 'marking status' tables #41

Closed
tim3dwards opened this Issue Oct 10, 2017 · 9 comments

Comments

Projects
None yet
3 participants
@tim3dwards

tim3dwards commented Oct 10, 2017

Hi NED guys,

First off, thanks kindly for the awesome plugin!

We've discovered a problem with the 'marking status' tables that get put together to show correct / incorrect answers for a quiz. Only correct answers get added to the table, questions manually graded as incorrect (and description type questions) don't get included in the table as I presume they should.

As such, the ticks for correct answers do not line up with the relevant questions on the 'marking status' page.

If you look at the attached screenshot, the top half shows how a quiz was manually graded. You'll see there's 4 description type questions throughout the quiz. The first 5 gradable questions were marked '0', the last 5 marked '1'.

Now, look at the bottom half of the screenshot, which shows the table Marking Manager created to depict these scores. You'll notice only the correct answers are displayed, and do not correspond with the relevant questions. Below, in the orange outline, is a table I quickly mocked up in Photoshop which shows how I would expect the table to be displayed.

Moodle version - 3.3.2+ (Build: 20170922)
Theme - Boost
NED Marking manager version - 3.3.1 (2017083001)

Hope that's of use, let me know if you've got any questions about this.

Thanks,

Tim.

ned-marking-manager-issue

@ned-code

This comment has been minimized.

Show comment
Hide comment
@ned-code

ned-code Oct 13, 2017

Owner

Hi Tim, Thanks for the screenshots. This issues is fixed in latest version, which can be downloaded here https://moodle.org/plugins/block_fn_marking

Owner

ned-code commented Oct 13, 2017

Hi Tim, Thanks for the screenshots. This issues is fixed in latest version, which can be downloaded here https://moodle.org/plugins/block_fn_marking

@ned-code ned-code closed this Oct 13, 2017

@tim3dwards

This comment has been minimized.

Show comment
Hide comment
@tim3dwards

tim3dwards Oct 13, 2017

tim3dwards commented Oct 13, 2017

@ned-code

This comment has been minimized.

Show comment
Hide comment
@ned-code

ned-code Oct 13, 2017

Owner

Yesterday

Owner

ned-code commented Oct 13, 2017

Yesterday

@tim3dwards

This comment has been minimized.

Show comment
Hide comment
@tim3dwards

tim3dwards Oct 13, 2017

tim3dwards commented Oct 13, 2017

@ned-code

This comment has been minimized.

Show comment
Hide comment
@ned-code

ned-code Oct 13, 2017

Owner

Can you try to clear your cache? If that doesn't work, please post your screenshot again. I can't see it in your previous message.

Owner

ned-code commented Oct 13, 2017

Can you try to clear your cache? If that doesn't work, please post your screenshot again. I can't see it in your previous message.

@ned-code ned-code reopened this Oct 13, 2017

@tim3dwards

This comment has been minimized.

Show comment
Hide comment
@tim3dwards

tim3dwards Oct 13, 2017

tim3dwards commented Oct 13, 2017

@tim3dwards

This comment has been minimized.

Show comment
Hide comment
@tim3dwards

tim3dwards Oct 13, 2017

I cleared Chrome browser cache in its entirety, and also purged the cache in Moode. Below is a screenshot using build 33_20171001200

image

tim3dwards commented Oct 13, 2017

I cleared Chrome browser cache in its entirety, and also purged the cache in Moode. Below is a screenshot using build 33_20171001200

image

@ned-code

This comment has been minimized.

Show comment
Hide comment
@ned-code

ned-code Oct 17, 2017

Owner

Hi Tim, please test latest Github code to see if this resolves this issue.

Owner

ned-code commented Oct 17, 2017

Hi Tim, please test latest Github code to see if this resolves this issue.

@tim3dwards

This comment has been minimized.

Show comment
Hide comment
@tim3dwards

tim3dwards Oct 17, 2017

tim3dwards commented Oct 17, 2017

@ned-code ned-code closed this Oct 22, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment