Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

continuation characters not properly recorded before strings #30

Closed
nedbat opened this issue Nov 15, 2009 · 1 comment
Closed

continuation characters not properly recorded before strings #30

nedbat opened this issue Nov 15, 2009 · 1 comment
Labels
bug Something isn't working

Comments

@nedbat
Copy link
Owner

nedbat commented Nov 15, 2009

Originally reported by Danek Duvall (Bitbucket: dhduvall, GitHub: dhduvall)


See the attached file. The first continuation character is accounted for correctly in the html output, but the other two are not, making it rather difficult to figure out what's going on in the rest of the file.

phys_tokens() makes this behavior explicit, so there's presumably some specific reason for this, but I don't understand why.


@nedbat
Copy link
Owner Author

nedbat commented Nov 15, 2009

Fixed in <<changeset 21828ef6d62d (bb)>>.

@nedbat nedbat closed this as completed Nov 15, 2009
@nedbat nedbat added major bug Something isn't working labels Jun 23, 2018
agronholm added a commit to agronholm/coveragepy that referenced this issue Aug 16, 2020
Also added test to make sure it doesn't break again.

Fixes nedbat#30.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working
Projects
None yet
Development

No branches or pull requests

1 participant