Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unexpectedly missing coverage + strange report format (PyPy3 7.1.1) #943

Closed
vytas7 opened this issue Feb 23, 2020 · 4 comments
Closed

Unexpectedly missing coverage + strange report format (PyPy3 7.1.1) #943

vytas7 opened this issue Feb 23, 2020 · 4 comments
Labels
bug fixed

Comments

@vytas7
Copy link

vytas7 commented Feb 23, 2020

Describe the bug
Coverage is reportedly missing on one line.
Moreover, that line is reported using a strange format, just: -96.
The mentioned line 96 is whitespace, FWIW.
The summary docs don't provide any similar example wrt the observed format.

To Reproduce
Run tox for this pull request on PyPy3 7.1.1: vytas7/falcon-sqla#4.
Reproduced thrice by rerunning the job.
This is the original failure: https://travis-ci.org/vytas7/falcon-sqla/jobs/654144248#L285

Expected behavior
Expected 100% coverage.
If there was a bug in the code and/or the test suite, expecting to get a clear indication what was not covered.

@vytas7 vytas7 added the bug label Feb 23, 2020
@vytas7 vytas7 changed the title Unexpectedly missing coverage + strange report format Unexpectedly missing coverage + strange report format (PyPy3) Feb 23, 2020
@nedbat
Copy link
Owner

nedbat commented Feb 24, 2020

Hmm, that is weird. The PyPy version in particular on Travis is pypy3.6-7.1.1 . I'll try reproducing this myself.

@vytas7
Copy link
Author

vytas7 commented Feb 24, 2020

FWIW, we've resolved this by retargeting to PyPy 7.2.0 found on Travis Ubuntu 18.04. 7.3.0 is unavailable in Travis OoB but everything passes in the pypy:3 Docker image as well.

The only question remaining I guess is whether this is a pure PyPy bug, or it reveals any edge case in coveragepy as well.

@vytas7 vytas7 changed the title Unexpectedly missing coverage + strange report format (PyPy3) Unexpectedly missing coverage + strange report format (PyPy3 7.1.1) Feb 24, 2020
@nedbat
Copy link
Owner

nedbat commented Feb 24, 2020

Thanks for the interesting bug!

Fixed (for PyPy 7.1) in 6f4c0dc

@nedbat
Copy link
Owner

nedbat commented Mar 17, 2020

This is now available in coverage v5.0.4

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug fixed
Projects
None yet
Development

No branches or pull requests

2 participants