Skip to content
master
Switch branches/tags
Code
This branch is up to date with master.
Contribute

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
bin
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 
 
 

multirb

Runs an IRB-esque prompt (but it's NOT really IRB!) over multiple Rubies using RVM or RBENV.

Screencast

Note: This is NOT the same as multiruby although multiruby has similar uses for fuller scripts and may be worth checking out.

Why is this useful?

If you're a regular developer, it's probably not very useful. But if you're researching or training people in the differences between versions and implementations of Ruby, it could be very helpful indeed.

This system was used in a different form in the Ruby 1.9 Walkthrough and is now being used to develop the Ruby 2.0 Walkthrough. Multirb allows me to quickly demonstrate the ways in which different versions of Ruby handle or support various features.

Installation

Install with:

$ gem install multirb

You also need a complete, working RVM or RBENV installation. Feel free to submit pull requests to make this auto detect other Ruby version managers.

Note: multirb works fine from MRI Ruby 1.9 and JRuby 1.7.x but has not been tested elsewhere yet.

Usage

Run with:

$ multirb

Or if you want to specify some different 'default' versions of Ruby to run:

$ multirb 1.9.2 1.9.3 [etc..]

Then:

  1. Type in expressions and press Enter.
  2. Leave whitespace on the end of lines to enter more lines.
  3. Add # all to run all versions, nothing for default.
  4. Add # version,version,version to run specific versions (e.g. # 1.9.2, 1.9.3.)
  5. Type exit on its own to exit (or use Ctrl+D.)

Currently specifies jruby, 1.8.7, 1.9.2, 1.9.3, and 2.0.0 as 'all versions'; 1.8.7, 1.9.3, and 2.0.0 as 'default versions'.

Versions

0.0.5 (current gem release):

  • fixes a Ruby version detection bug triggered by interpolation (found by dalton)

0.0.4:

  • rbenv support

0.0.3:

  • acts nicely when using Ctrl+D to exit rather than raising a needless error
  • uses Ruby 2.0.0-rc2 as a default

0.0.2:

  • Uses threads to speed up results (thanks to Ismael Abreu for initial implementation)
  • Improved 'tempfile' usage to prevent errors on JRuby

0.0.1

  • Initial version

Contributing

  1. Fork it
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request

About

Run Ruby code over multiple implementations/versions using RVM from a IRB-esque prompt

Resources

License

Packages

No packages published

Languages