Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Tag 2.0 seems to be broken #84

Closed
ricardclau opened this Issue Oct 15, 2012 · 5 comments

Comments

Projects
None yet
3 participants
Contributor

ricardclau commented Oct 15, 2012

Hi

I was trying to use a "stable" release and I used in my composer.json

    "nelmio/api-doc-bundle":"2.*@stable",

Which downloads version 2.0.0 of the bundle

But when trying to generate my api documentation I get the following error:

Call to undefined method Symfony\Component\Routing\CompiledRoute::getRequirements() in /datos/socialpoint/sp-platform-dragoncity/vendor/nelmio/api-doc-bundle/Nelmio/ApiDocBundle/Extractor/ApiDocExtractor.php on line 234

This is a line where

    foreach ($route->compile()->getRequirements() as $name => $value) {

And CompiledRoute.php from SF2.1 does not have getRequirements method (Route.php, does have it, however). I am using Symfony 2.1.2.

Using composer.json pointing to dev-master works but we would like to have tagged versions

Can you confirm this issue and if confirmed get this tag to be fixed?

Best regards

Owner

Seldaek commented Oct 15, 2012

Yup there have been a ton of changes and we probably should tag a 2.1.0 - for now please use dev-master

Contributor

ricardclau commented Oct 15, 2012

Can we please leave this open until a 2.1.0 is tagged and this way me and people having same issue can get notified?

Owner

Seldaek commented Oct 15, 2012

Yes I left it open on purpose as a reminder :)

Contributor

ricardclau commented Oct 15, 2012

Great then! Thanks! And congratulations for such a great bundle :)

Collaborator

willdurand commented Mar 17, 2013

I've just tagged a 2.1.0.

@willdurand willdurand closed this Mar 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment