Permalink
Browse files

Update READMEs with additional dependency info.

The plugin only works if:

* vi-compatible mode is disabled
* filetype plugins are enabled
  • Loading branch information...
1 parent ea53988 commit c6b186dd5ad74503439c967e0d2ad863fcba93bc @nelstrom committed Jan 26, 2011
Showing with 16 additions and 0 deletions.
  1. +7 −0 README.md
  2. +9 −0 readme.vim.org
View
@@ -9,6 +9,13 @@ Also requires that the matchit.vim plugin is enabled. Ensure that the following
runtime macros/matchit.vim
+It is also essential that you enable filetype plugins, and disable Vi compatible mode. Placing these lines in your vimrc file will do this:
+
+ set nocompatible
+ if has("autocmd")
+ filetype indent plugin on
+ endif
+
Usage
=====
View
@@ -76,6 +76,15 @@ can be achieved by running (or placing this in your vimrc file):
:runtime macros/matchit.vim
+Finally, you need to ensure that Vim is not running in vi-compatiable mode, and
+that filetype plugins are enabled. Placing these lines in your vimrc file will
+set up this configuration for you:
+
+ set nocompatible
+ if has("autocmd")
+ filetype indent plugin on
+ endif
+
This plugin is distributed as a vimball, so to install it you just need to
open the file with Vim and run the command:

0 comments on commit c6b186d

Please sign in to comment.