Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: e5aca2d177
Fetching contributors…

Cannot retrieve contributors at this time

100 lines (98 sloc) 3.127 kb
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.neo4j.build</groupId>
<artifactId>parent-central</artifactId>
<version>25</version>
<relativePath/>
</parent>
<artifactId>docs-maven-plugin</artifactId>
<groupId>org.neo4j.build.plugins</groupId>
<packaging>maven-plugin</packaging>
<version>0.1-SNAPSHOT</version>
<name>docs Maven Mojo</name>
<url>http://maven.apache.org</url>
<dependencies>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-plugin-api</artifactId>
<version>3.0.3</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-core</artifactId>
<version>3.0.3</version>
</dependency>
<dependency>
<groupId>org.twdata.maven</groupId>
<artifactId>mojo-executor</artifactId>
<version>2.0</version>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
</dependency>
<dependency>
<groupId>org.apache.maven.shared</groupId>
<artifactId>maven-filtering</artifactId>
<version>1.0</version>
</dependency>
<dependency>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-assembly-plugin</artifactId>
<version>2.2.1</version>
</dependency>
</dependencies>
<build>
<pluginManagement>
<plugins>
<plugin>
<artifactId>docs-maven-plugin</artifactId>
<groupId>org.neo4j.build.plugins</groupId>
<version>0.1-SNAPSHOT</version>
<!-- the directories below will be added by default,
using the config element will _replace_ the defaults. -->
<!--
<configuration>
<sourceDirectories>
<sourceDirectory>${basedir}/src/docs</sourceDirectory>
<sourceDirectory>${project.build.directory}/docs</sourceDirectory>
</sourceDirectories>
</configuration>
-->
<!--
<configuration>
<executions>
<execution>
<id>assemble-docs</id>
<phase>package</phase>
<goals><goal>assemble</goal></goals>
</execution>
</executions>
</configuration>
-->
</plugin>
</plugins>
</pluginManagement>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-plugin</artifactId>
</plugin>
<plugin>
<artifactId>docs-maven-plugin</artifactId>
<groupId>org.neo4j.build.plugins</groupId>
</plugin>
<plugin>
<artifactId>maven-jar-plugin</artifactId>
<executions>
<execution>
<id>attach-docs</id>
<phase>none</phase>
</execution>
</executions>
</plugin>
</plugins>
</build>
</project>
Jump to Line
Something went wrong with that request. Please try again.