New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support for HA when using Embedded Driver #142

Closed
vince-bickers opened this Issue Apr 6, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@vince-bickers

vince-bickers commented Apr 6, 2016

@vince-bickers

This comment has been minimized.

Show comment
Hide comment
@vince-bickers

vince-bickers Nov 9, 2016

You can now add an additional config setting to the ogm.properties file, e.g:

neo4j.ha.properties.file = neo4j-ha.properties

The EmbeddedDriver will detect this configuration setting and pass the associated properties file to the HighlyAvailableGraphDatabaseFactory. In the absence of this property, the community GraphDatabaseFactory will be used instead.

Example neo4j-ha.properties file, that will start a single-node high-availability instance:

ha.server_id=1
ha.initial_hosts=localhost:5001
ha.allow_init_cluster=true

You can call the ha properties file referenced by the config setting whatever you like, but it must be on the classpath.

Supports Neo4j 2.3.x and Neo4j 3.0.x and available in the latest 2.1.0-SNAPSHOT release

vince-bickers commented Nov 9, 2016

You can now add an additional config setting to the ogm.properties file, e.g:

neo4j.ha.properties.file = neo4j-ha.properties

The EmbeddedDriver will detect this configuration setting and pass the associated properties file to the HighlyAvailableGraphDatabaseFactory. In the absence of this property, the community GraphDatabaseFactory will be used instead.

Example neo4j-ha.properties file, that will start a single-node high-availability instance:

ha.server_id=1
ha.initial_hosts=localhost:5001
ha.allow_init_cluster=true

You can call the ha properties file referenced by the config setting whatever you like, but it must be on the classpath.

Supports Neo4j 2.3.x and Neo4j 3.0.x and available in the latest 2.1.0-SNAPSHOT release

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment