Fails to install on RHEL7 via Linuxbrew (SOLVED: brew reinstall -s libtool) #164

Closed
satyenr opened this Issue Jul 11, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@satyenr

satyenr commented Jul 11, 2016

I am getting the following error.

==> cmake ../third-party -DUSE_BUNDLED_BUSTED=OFF -DUSE_BUNDLED_LUV=OFF -DUSE_EXISTING_SRC_DIR=ON -DCMAKE_C_FLAGS_RELEASE=-DNDEBUG -DCMAKE_CXX_FLAGS_RELEASE=-DNDEBUG -DCMAKE_INSTALL_PREFIX=/home/satyenr/Brew/Cellar/neovim/0.1.4 -DCMAKE_BUILD_TYPE=Release -
==> make VERBOSE=1
Last 15 lines from /home/satyenr/.cache/Homebrew/Logs/neovim/02.make:
libtool: compile:  /home/satyenr/Brew/bin/gcc-5 -I. -Wall -std=c99 -fPIC -c uninames.c  -fPIC -DPIC -o .libs/uninames.o
libtool: compile:  /home/satyenr/Brew/bin/gcc-5 -I. -Wall -std=c99 -fPIC -c uninames.c -o uninames.o >/dev/null 2>&1
libtool --mode=compile --tag=CC /home/satyenr/Brew/bin/gcc-5 -I. -DTERMINFO_DIRS='"/etc/terminfo:/lib/terminfo:/usr/share/terminfo:/usr/lib/terminfo:/usr/local/share/terminfo:/usr/local/lib/terminfo"' -Wall -std=c99 -fPIC  -o uniutil.lo -c uniutil.c
libtool: compile:  /home/satyenr/Brew/bin/gcc-5 -I. -DTERMINFO_DIRS=\"/etc/terminfo:/lib/terminfo:/usr/share/terminfo:/usr/lib/terminfo:/usr/local/share/terminfo:/usr/local/lib/terminfo\" -Wall -std=c99 -fPIC -c uniutil.c  -fPIC -DPIC -o .libs/uniutil.o
libtool: compile:  /home/satyenr/Brew/bin/gcc-5 -I. -DTERMINFO_DIRS=\"/etc/terminfo:/lib/terminfo:/usr/share/terminfo:/usr/lib/terminfo:/usr/local/share/terminfo:/usr/local/lib/terminfo\" -Wall -std=c99 -fPIC -c uniutil.c -o uniutil.o >/dev/null 2>&1
libtool --mode=link --tag=CC /home/satyenr/Brew/bin/gcc-5 -L/home/satyenr/Brew/lib -Wl,--dynamic-linker=/home/satyenr/Brew/lib/ld.so -Wl,-rpath,/home/satyenr/Brew/lib -rpath '/tmp/neovim-20160711-131712-1c560kf/neovim-0.1.4/deps-build/usr/lib' -version-info 3:0:3 -o libunibilium.la unibilium.lo uninames.lo uniutil.lo
libtool: link: /usr/bin/gcc-4.8 -shared  -fPIC -DPIC  .libs/unibilium.o .libs/uninames.o .libs/uniutil.o   -L/home/satyenr/Brew/lib  -Wl,--dynamic-linker=/home/satyenr/Brew/lib/ld.so -Wl,-rpath -Wl,/home/satyenr/Brew/lib   -Wl,-soname -Wl,libunibilium.so.0 -o .libs/libunibilium.so.0.3.0
/home/satyenr/Brew/bin/libtool: line 10548: /usr/bin/gcc-4.8: No such file or directory
make[3]: *** [libunibilium.la] Error 127
make[3]: Leaving directory `/tmp/neovim-20160711-131712-1c560kf/neovim-0.1.4/deps-build/build/src/unibilium'
make[2]: *** [build/src/unibilium-stamp/unibilium-build] Error 2
make[2]: Leaving directory `/tmp/neovim-20160711-131712-1c560kf/neovim-0.1.4/deps-build'
make[1]: *** [CMakeFiles/unibilium.dir/all] Error 2
make[1]: Leaving directory `/tmp/neovim-20160711-131712-1c560kf/neovim-0.1.4/deps-build'
make: *** [all] Error 2

Thanks
Satyen

@justinmk

This comment has been minimized.

Show comment
Hide comment
@justinmk

justinmk Jul 11, 2016

Member

Looks the same as this post: http://stackoverflow.com/a/37877263/152142 . Quoting the answer:

It is a problem of the libtool formula Linuxbrew/homebrew-core#376
I fixed by doing

brew update
brew reinstall -s libtool
brew install neovim/neovim/neovim
Member

justinmk commented Jul 11, 2016

Looks the same as this post: http://stackoverflow.com/a/37877263/152142 . Quoting the answer:

It is a problem of the libtool formula Linuxbrew/homebrew-core#376
I fixed by doing

brew update
brew reinstall -s libtool
brew install neovim/neovim/neovim

@justinmk justinmk closed this Jul 11, 2016

@justinmk justinmk changed the title from Fails to install on RHEL7 via Linuxbrew to Fails to install on RHEL7 via Linuxbrew (SOLVED: brew reinstall -s libtool) Jul 11, 2016

@satyenr

This comment has been minimized.

Show comment
Hide comment
@satyenr

satyenr Jul 11, 2016

Thanks! Don't know how I missed that SO question.

satyenr commented Jul 11, 2016

Thanks! Don't know how I missed that SO question.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment