Skip to content
This repository
Newer
Older
100644 49 lines (42 sloc) 1.863 kb
6ceacc4c »
2011-11-30 initial commit
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "gitdocs/version"
4
5 Gem::Specification.new do |s|
6 s.name = "gitdocs"
7 s.version = Gitdocs::VERSION
2498af88 »
2011-11-30 Update gemspec
8 s.authors = ["Josh Hull", "Nathan Esquenazi"]
9 s.email = ["joshbuddy@gmail.com", "nesquena@gmail.com"]
10 s.homepage = "http://engineering.gomiso.com/2011/11/30/collaborate-and-track-tasks-with-ease-using-gitdocs/"
11 s.summary = %q{Open-source Dropbox using Ruby and Git}
12 s.description = %q{Open-source Dropbox using Ruby and Git.}
6ceacc4c »
2011-11-30 initial commit
13
14 s.rubyforge_project = "gitdocs"
15
16 s.files = `git ls-files`.split("\n")
17 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
18 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
19 s.require_paths = ["lib"]
20
0a7c8629 »
2014-01-07 Dropping support for ruby1.8
21 s.required_ruby_version = '>= 1.9'
22
fb4871ad »
2011-12-10 Gemspec reflects reality. I published a new guard
23 s.add_dependency 'joshbuddy-guard', '~> 0.10.0'
20141ec8 »
2013-10-14 Upgrade thin gem to the v1.5.1
24 s.add_dependency 'thin', '~> 1.5.1'
25 s.add_dependency 'renee', '~> 0.3.11'
b0561a5b »
2014-03-04 upgrade redcarpet to 3.1.1 to fix markdown rendering
26 s.add_dependency 'redcarpet', '~> 3.1.1'
1b237c19 »
2011-12-29 More robust EM loop and restarting
27 s.add_dependency 'thor', '~> 0.14.6'
28 s.add_dependency 'coderay', '~> 1.0.4'
1d7d801e »
2011-12-06 Use new dante to cleanup cli start/stop logic
29 s.add_dependency 'dante', '~> 0.1.2'
6ceacc4c »
2011-11-30 initial commit
30 s.add_dependency 'growl', '~> 1.0.3'
1b237c19 »
2011-12-29 More robust EM loop and restarting
31 s.add_dependency 'yajl-ruby', '~> 1.1.0'
32 s.add_dependency 'haml', '~> 3.1.4'
5b9a8556 »
2011-12-03 new config stuff
33 s.add_dependency 'sqlite3', "~> 1.3.4"
34 s.add_dependency 'activerecord', "~> 3.1.0"
6b414767 »
2011-12-05 use grit to get remotes
35 s.add_dependency 'grit', "~> 2.4.1"
ab880111 »
2011-12-06 fix path escaping
36 s.add_dependency 'shell_tools', "~> 0.1.0"
a571b0cc »
2011-12-14 Uses mimetype-fu for mimetypes and fixes a bunch of related issues
37 s.add_dependency 'mimetype-fu', "~> 0.1.2"
20141ec8 »
2013-10-14 Upgrade thin gem to the v1.5.1
38 s.add_dependency 'eventmachine', '>= 1.0.3'
4c95ffc5 »
2013-12-31 Update the initial UI open to use Launchy
39 s.add_dependency 'launchy', '~> 2.4.2'
517ea061 »
2014-02-03 Add rugged and use it from the integration tests
40 s.add_dependency 'rugged', '~> 0.19.0'
6ceacc4c »
2011-11-30 initial commit
41
20141ec8 »
2013-10-14 Upgrade thin gem to the v1.5.1
42 s.add_development_dependency 'minitest', "~> 5.0.8"
6ceacc4c »
2011-11-30 initial commit
43 s.add_development_dependency 'rake'
44 s.add_development_dependency 'mocha'
45 s.add_development_dependency 'fakeweb'
0a7c8629 »
2014-01-07 Dropping support for ruby1.8
46 s.add_development_dependency 'metric_fu'
5c3b88a0 »
2014-02-02 Add Aruba based integration tests in MiniTest
47 s.add_development_dependency 'aruba'
6ceacc4c »
2011-11-30 initial commit
48 end
Something went wrong with that request. Please try again.