Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error when nest.helpdesk() is called with Python < 2.7.8 #748

Closed
janhahne opened this issue Jun 9, 2017 · 2 comments
Closed

Error when nest.helpdesk() is called with Python < 2.7.8 #748

janhahne opened this issue Jun 9, 2017 · 2 comments

Comments

@janhahne
Copy link

@janhahne janhahne commented Jun 9, 2017

When I install NEST with Python 2.7.6 and then call nest.helpdesk() in python I get an error that the file helpindex.html does not exist. If I call nest.help('iaf_psc_alpha') (or any other NEST object) i get the - of course somehow right - answer Sorry, there is no help for 'iaf_psc_alpha'!

I assume this behavior results from the combination of PR #688 and #715.

When I call nest.helpdesk() or nest.help(object) with Python 2.7.6 I would expect an information as The NEST help is not available due to a Python version older than 2.7.8. Otherwise it is unclear to the user what is going wrong - there is no message at all, neither when the help is accessed via python nor while cmake (which might be useful as well?)

@heplesser
Copy link
Contributor

@heplesser heplesser commented Jun 12, 2017

@steffengraber Could you take a look at this? I think @janhahne's suggestion to print

NEST Help is not available on Python 2.7.7 and earlier.
@steffengraber
Copy link
Collaborator

@steffengraber steffengraber commented Jun 13, 2017

@janhahne @heplesser There is a little fix: #751.
Please test and review it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.