Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix issue #678 - Skip help generation without python or python older than 2.7.8 #715

Merged
merged 2 commits into from Jun 9, 2017

Conversation

@steffengraber
Copy link
Collaborator

@steffengraber steffengraber commented May 5, 2017

Getting python from CMake variables and using this instead of the hard coded python. Skipping help generation if no python is found or the version is older than 2.7.8.

This is a fix for issue #678 and #712

Using cmake expressions to check for python.
Copy link
Contributor

@heplesser heplesser left a comment

Looks fine to me except for a tiny details.


find_package( PythonInterp )
if ( PYTHONINTERP_FOUND )
if(${PYTHON_VERSION_STRING} VERSION_GREATER "2.7.7")

This comment has been minimized.

@heplesser

heplesser May 8, 2017
Contributor

I think it would be useful to add a comment explaining why we require a version > 2.7.8, including a reference to #678. Also, add spaces around the parenthesis if ( ... ).

@andresni
Copy link

@andresni andresni commented Jun 2, 2017

Confirmed fix for python 3.6 system.

@heplesser heplesser merged commit 66cd46e into nest:master Jun 9, 2017
1 check passed
1 check passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@steffengraber steffengraber deleted the steffengraber:fix-issue-678 branch Mar 5, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.