New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support linking against topology when building extension modules #903

Merged
merged 1 commit into from Mar 8, 2018

Conversation

Projects
None yet
4 participants
@heplesser
Contributor

heplesser commented Mar 7, 2018

This PR fixes #841 by adding topology to ALL_LIBS, the CMake variable listing all libraries against which to link when, e.g., building extension modules.

I assume it worked on some systems because there linkers delayed look-up until runtime. Since topology was loaded on NEST startup, the necessary symbols are available when loading the module at runtime.

@TomBugnon Could you test if this fix solves your problem?

@TomBugnon

This comment has been minimized.

Show comment
Hide comment
@TomBugnon

TomBugnon Mar 7, 2018

That works for both masks and kernels, thank you so much. Good bye docker!

TomBugnon commented Mar 7, 2018

That works for both masks and kernels, thank you so much. Good bye docker!

@stinebuu

Nice!

@jougs

This comment has been minimized.

Show comment
Hide comment
@jougs

jougs Mar 8, 2018

Contributor

Many thanks for addressing the issue. Given two positive reviews, I merge.

Contributor

jougs commented Mar 8, 2018

Many thanks for addressing the issue. Given two positive reviews, I merge.

@jougs jougs merged commit 03682cf into nest:master Mar 8, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@heplesser heplesser deleted the heplesser:fix-841-module-link-problem branch Mar 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment