cannot load such file -- net/ssh/authentication/agent/socket in 2.5.0 #43

Closed
pshoukry opened this Issue May 24, 2012 · 6 comments

Comments

Projects
None yet
4 participants

Rails 3.2 not starting with error
cannot load such file -- net/ssh/authentication/agent/socket

on both ruby 1.9.3-p194 and ruby 1.9.2-p320

quick work around is to force the 2.4.0 version

They forgot to update gemspec. Use of auto-generated gemspec from bundler is better.

Yup, I am fine with the 2.4.0 branch (I am not directly using the gem its a dependency) but just wanted to highlight it to be fixed in upcoming releases.

Thanks

👍 Big failed on this release :(

delano added a commit that referenced this issue May 24, 2012

Collaborator

delano commented May 24, 2012

Fixed in 2.5.1. Thanks for the report and patch.

@delano delano closed this May 24, 2012

Thanks for the quick response / Fix

NameError: uninitialized constant Net::SSH::KnownHosts::SUPPORTED_TYPE

Sad but true (

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment