New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spotify, Arch: ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD #2080

Closed
brakenow opened this Issue Aug 12, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@brakenow

brakenow commented Aug 12, 2018

A blank window opens, and Xorg freezes. Also with the git version.

@Vincent43

This comment has been minimized.

Show comment
Hide comment
@Vincent43

Vincent43 Aug 12, 2018

Collaborator

What is your graphic card? Can you try with firejail --noblacklist=/sys spotify ?

Collaborator

Vincent43 commented Aug 12, 2018

What is your graphic card? Can you try with firejail --noblacklist=/sys spotify ?

@brakenow

This comment has been minimized.

Show comment
Hide comment
@brakenow

brakenow Aug 13, 2018

Thanks. Will try it when I wake up. Intel® UHD Graphics 630

brakenow commented Aug 13, 2018

Thanks. Will try it when I wake up. Intel® UHD Graphics 630

@brakenow

This comment has been minimized.

Show comment
Hide comment
@brakenow

brakenow Aug 14, 2018

It worked! But I still get:

ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/usr/share/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /usr/share/spo
ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/usr/share/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /usr/share/spo
ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/proc/self/exe: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)
[0814/084452.829167:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization

Tried without firejail and the ERROR's appear then too, so not firejail related.

Thank you! :-D

brakenow commented Aug 14, 2018

It worked! But I still get:

ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/usr/share/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /usr/share/spo
ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/usr/share/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /usr/share/spo
ERROR: ld.so: object 'libcurl.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
/proc/self/exe: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)
[0814/084452.829167:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization

Tried without firejail and the ERROR's appear then too, so not firejail related.

Thank you! :-D

@brakenow brakenow closed this Aug 14, 2018

Vincent43 added a commit that referenced this issue Aug 14, 2018

spotify.profile: remove /sys from blacklist
Blacklisting whole /sys is too restrictive, it may break various graphics stacks, see #2080
@Vincent43

This comment has been minimized.

Show comment
Hide comment
@Vincent43

Vincent43 Aug 15, 2018

Collaborator

This is fixed in master with 516f8d0

Collaborator

Vincent43 commented Aug 15, 2018

This is fixed in master with 516f8d0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment