New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

debian packaging issue: netmagis-database dependency on postgresql-pltcl-9.1 is invalid for debian jessie #129

sgsax opened this Issue Jun 10, 2014 · 0 comments


None yet
2 participants

sgsax commented Jun 10, 2014

Package dependencies for netmagis-database are listed as follows:
Depends: netmagis-common, tcl (>= 8.5), postgresql (>= 9.1), postgresql-pltcl-9.1, pwgen (>= 2.0)

With Debian jessie release, postgresql-pltcl package is postgresql-pltcl-9.3, -9.1 isn't available. Attempting to install netmagis-database results in the following error:
The following packages have unmet dependencies:
netmagis-database : Depends: postgresql-pltcl-9.1 but it is not installable
E: Unable to correct problems, you have held broken packages.

Really, the upstream package maintainer should publish a package without the version included in the name. But for netmagis, it would help if you could build the package so that it will recognize the newer library, or at least an alternative version for jessie.


@pdav pdav added this to the v2.2.3 milestone Jun 26, 2014

@pdav pdav closed this Sep 10, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment