New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compatibility with Mage 2.2.7 and 2.3 / PHP 7.2 #44

Open
simonmaass opened this Issue Dec 6, 2018 · 17 comments

Comments

Projects
None yet
4 participants
@simonmaass
Copy link

simonmaass commented Dec 6, 2018

Feature description
Any feedback for 2.2.7 and 2.3 support?

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Dec 6, 2018

@simonmaass
Can you be a bit more specific please?

  • You asked for feedback. Was this an open issue? I don't see one.
  • Did you try it and didn't it work?
  • If it didn't work, what was the exact problem / error message / etc.?
@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Dec 6, 2018

@ngolatka we wanted to know if you have any experience with the compaibility of the 0.9.1 version with magento 2.3

we upgrade to 2.2.7 and it seems to work btw...

@ngolatka ngolatka added the question label Dec 6, 2018

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Dec 12, 2018

@ngolatka it is not an open issue but a question - when will there be an official 2.3 support?

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Dec 12, 2018

Hi @simonmaass , thanks for clarifying. At the moment, there is no definitive answer to that question though.

Generally speaking, the development work will of course be based on current Magento versions, so there will probably be support for Mage 2.3 in the future, but I can't tell you when that will happen.

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Dec 31, 2018

are there any other ways in connecting your magento 2.3 with DHL? How are DHL customers suppose to work with magento? Would be great if support would be there soon!

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 2, 2019

We are currently checking what needs to be done in the DHL extension.

There is no timeline yet, but we will keep you posted in this issue.

@ngolatka ngolatka added enhancement and removed question labels Jan 2, 2019

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 3, 2019

The upcoming version 0.10.0 is going to be compatible with Magento 2.3.

Timeline: If everything goes according to plan and we don't get any surprises, the release should happen this month. Keep an eye on the list of releases.

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Jan 3, 2019

@ngolatka thank you for the info!

@Mandrino

This comment has been minimized.

Copy link

Mandrino commented Jan 6, 2019

This timely 2.3 support is greatly appreciated! Thanks!

@gewaechshaus

This comment has been minimized.

Copy link
Contributor

gewaechshaus commented Jan 11, 2019

Hi @ngolatka - please also add php 7.2 support. Many thanks

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 14, 2019

@gewaechshaus Already done. Version 0.10.0 will include support for PHP 7.2

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Jan 15, 2019

is there any timeline that can be communicated? are u currently working on it? is it this week or next?

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 16, 2019

@simonmaass As I wrote above:

the release should happen this month.

Yes, we are working on it right now, but we can't be more specific about the date. There's always the remote possibility that some unexpected last-minute changes need to be done.

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Jan 23, 2019

any update here?

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 23, 2019

@simonmaass
I have a keen eye on this. But please refrain from "ping" messages. I wrote:

the release should happen this month.

This month is not over yet.

@ngolatka

This comment has been minimized.

Copy link
Contributor

ngolatka commented Jan 28, 2019

A quick heads up:
Earlier I wrote "if we don't get any surprises, the release should happen this month". I think I have tempted fate by saying that ;-)

The bloody flu knocked out our team. The remaining people are still working on the release, but it may take a bit longer (can't say how long exactly).

@simonmaass

This comment has been minimized.

Copy link
Author

simonmaass commented Jan 28, 2019

@ngolatka thnx for the heads up

@ngolatka ngolatka changed the title Compatibility 2.2.7 and 2.3 Compatibility with Mage 2.2.7 and 2.3 / PHP 7.2 Jan 29, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment