Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

nette/application 2.4 is not compatible with nette/utils 3.0 #210

Closed
xificurk opened this issue Feb 24, 2019 · 1 comment
Closed

nette/application 2.4 is not compatible with nette/utils 3.0 #210

xificurk opened this issue Feb 24, 2019 · 1 comment

Comments

@xificurk
Copy link
Contributor

@xificurk xificurk commented Feb 24, 2019

Version: 2.4.x

Bug Description

composer.json allows nette/utils ~3.0.0, but it's not compatible because of at leaset one missing return type:
Fatal error: Declaration of Nette\Application\Routers\RouteList::offsetSet($index, $route) must be compatible with Nette\Utils\ArrayList::offsetSet($index, $value): void

Possible Solution

Probably the only way out of this is to remove nette/utils 3.0 from allowed dependencies.

dg added a commit that referenced this issue Feb 24, 2019
@dg

This comment has been minimized.

Copy link
Member

@dg dg commented Feb 24, 2019

Fixed

@dg dg closed this Feb 24, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.