Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

nette/di does not allow installing latest php-generator #182

Closed
stof opened this issue Nov 23, 2018 · 3 comments
Closed

nette/di does not allow installing latest php-generator #182

stof opened this issue Nov 23, 2018 · 3 comments

Comments

@stof
Copy link

@stof stof commented Nov 23, 2018

The requirement on nette/php-generator is ^2.6.1 || ~3.0.0. This means that composer will install the 3.0.5 release (highest release matching that range), while the latest release is 3.2.0.

Is this an expected change ? And is 3.0.x still maintained ? If no, the constraint should be changed either to force using a maintained 2.x version or to allow newer 3.x version.

@Jeroeny

This comment has been minimized.

Copy link

@Jeroeny Jeroeny commented Dec 27, 2018

I'm running into this issue as well. I can't install phpstan/phpstan and nette/php-generator at the same time.

@dg

This comment has been minimized.

Copy link
Member

@dg dg commented Dec 28, 2018

It is intended, nette/di 2.4 is not compatible with nette/php-generator 3.1.

@Jeroeny

This comment has been minimized.

Copy link

@Jeroeny Jeroeny commented Jan 2, 2019

Is it possible that I make a pull request to support this in a new version of nette/di?

dg added a commit that referenced this issue Jan 30, 2019
@dg dg closed this Jan 30, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.