Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and
privacy statement. We’ll occasionally send you account related emails.
Already on GitHub?
to your account
The requirement on nette/php-generator is ^2.6.1 || ~3.0.0. This means that composer will install the 3.0.5 release (highest release matching that range), while the latest release is 3.2.0.
^2.6.1 || ~3.0.0
Is this an expected change ? And is 3.0.x still maintained ? If no, the constraint should be changed either to force using a maintained 2.x version or to allow newer 3.x version.
The text was updated successfully, but these errors were encountered:
I'm running into this issue as well. I can't install phpstan/phpstan and nette/php-generator at the same time.
Sorry, something went wrong.
It is intended, nette/di 2.4 is not compatible with nette/php-generator 3.1.
Is it possible that I make a pull request to support this in a new version of nette/di?
compatibility with nette/php-generator 3.x [Closes #182]
No branches or pull requests