Permalink
Browse files

readme: php version requirements update (#20)

  • Loading branch information...
jkuchar authored and dg committed Aug 6, 2018
1 parent 0eb5fa3 commit 30a014434298413448185c494c0e1f64f7ca4508
Showing with 8 additions and 3 deletions.
  1. +8 −3 readme.md
@@ -14,7 +14,8 @@ If you like Nette, **[please make a donation now](https://nette.org/donate)**. T
Requirements
------------

PHP 5.6 or higher.
- Web Project for Nette 2.4 requires PHP 5.6
- The master version of Web Project requires PHP 7.1


Installation
@@ -45,13 +46,17 @@ should be ready to go.
**It is CRITICAL that whole `app/`, `log/` and `temp/` directories are not accessible directly
via a web browser. See [security warning](https://nette.org/security-warning).**


Notice: Composer PHP version
----------------------------
This project forces `PHP 5.6` as your PHP version for Composer packages. If you have newer version on production you should change it in `composer.json`.

This project forces PHP 5.6 (eventually 7.1) as your PHP version for Composer packages. If you have newer
version on production server you should change it in `composer.json`:

```json
"config": {
"platform": {
"php": "7.0"
"php": "7.2"
}
}
```

0 comments on commit 30a0144

Please sign in to comment.