Permalink
Browse files

Fixed a couple incompatibiltites with 1.9.2 aka SystemTimer and made …

…sure the specs still run for both ree-1.8.7 and ruby-1.9.2-p0.
  • Loading branch information...
1 parent 3996919 commit 417d51a6329e1b26a4038bf69cf57c929e1aaa3c @agnellvj agnellvj committed Jul 20, 2011
Showing with 4 additions and 2 deletions.
  1. +2 −0 bin/resque-pool
  2. +1 −1 resque-pool.gemspec
  3. +1 −1 spec/resque_pool_spec.rb
View
@@ -1,5 +1,7 @@
#!/usr/bin/env ruby
# -*- encoding: utf-8 -*-
+$LOAD_PATH.unshift File.expand_path('../../lib', __FILE__)
+
require 'resque/pool/cli'
Resque::Pool::CLI.run
View
@@ -21,7 +21,7 @@ Gem::Specification.new do |s|
s.add_development_dependency "rspec", "~> 2.3.0"
s.add_development_dependency "cucumber", "~> 0.10.0"
s.add_development_dependency "aruba", "~> 0.3.2"
- s.add_development_dependency "SystemTimer" # to silence redis gem's warning
+ s.add_development_dependency "SystemTimer" if RUBY_VERSION =~ /^1\.8/# to silence redis gem's warning
s.add_development_dependency "bundler", "~> 1.0"
# hidden files are automatically ignored by Dir.glob
@@ -1,4 +1,4 @@
-require 'spec/spec_helper'
+require 'spec_helper'
RSpec.configure do |config|
config.after {

0 comments on commit 417d51a

Please sign in to comment.