New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Slow clock mode for AVR doesn't work #103

Closed
jmichelp opened this Issue Feb 4, 2018 · 7 comments

Comments

Projects
None yet
5 participants
@jmichelp
Copy link
Contributor

jmichelp commented Feb 4, 2018

I tried but I only had python exceptions when this option is set. It's disconnecting the scope on the GUI and never was able to read a signature nor the fuses.

I can dig into the issue later but it the meantime if someone knows how to fix it... :)

@FranzHeubach

This comment has been minimized.

Copy link
Contributor

FranzHeubach commented Feb 5, 2018

Thank you for letting us know, one of us will look into it.

@colinoflynn

This comment has been minimized.

Copy link
Contributor

colinoflynn commented Feb 24, 2018

Oops - meant to look into this more....

"slow clock mode" only works once the AVR programmer is open. Is that still erroring out? Slow clock is a big hack that slows down the SAM3U core clock speed, as you can't divide the SPI clock to be low enough when running from the 96 MHz clock.

Everything else goes out the window when this happens - the FPGA communication etc won't work reliably once it's enabled.

@jmichelp

This comment has been minimized.

Copy link
Contributor

jmichelp commented Feb 26, 2018

Those are the steps I was following:

  • Put a new chip in the NOTDUINO socket
  • Connect CW-lite with NOTDUINO using connect_cwlite_simpleserial.py script
  • Setup the connection using setup_cwlite_notduino.py script
  • Open the AVR programmer
  • Click Enable slow clock mode
  • Click Check Signature or Read Fuses

And the following steps always resulted in an error and I ended up using an external programmer to set the fuses and be able to use the CW-lite to push firmware.

@yihan0512

This comment has been minimized.

Copy link

yihan0512 commented Oct 15, 2018

As of Oct 15th, 2018 I'm still having this issue.

@colinoflynn

This comment has been minimized.

Copy link
Contributor

colinoflynn commented Oct 16, 2018

I'll tag @alex-dewar to investigate a little here...

@alex-dewar

This comment has been minimized.

Copy link
Contributor

alex-dewar commented Oct 17, 2018

Should be fixed by 073aba8. Basically, the delays on the Sam3u became too long when in slow clock mode, causing USB to time out. ChipWhisperer now tells the Sam3u to use smaller delay values when in slow clock mode.

Let me know if the issue is fixed and I'll close it.

@yihan0512

This comment has been minimized.

Copy link

yihan0512 commented Oct 17, 2018

it worked, thank you! You can close this issue now.

@alex-dewar alex-dewar closed this Oct 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment