New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto Upload does not work. #2249

Closed
CrippinNRW opened this Issue Feb 28, 2018 · 132 comments

Comments

Projects
None yet
@CrippinNRW
Copy link

CrippinNRW commented Feb 28, 2018

Actual behaviour

Auto Upload does not work.
Manual Upload works. But if I take a Picture I get a Message with connection Problems

Environment data

Android version: 7.0

Device model:

Huawei Mate 10 Lite RNE-L21

Stock or customized system:

stock

Nextcloud app version:

3.0.2

Nextcloud server version:

13

@mario

This comment has been minimized.

Copy link
Member

mario commented Feb 28, 2018

Manual upload is pretty much the same as auto upload. So dunno where that's come from :( Only guess is you have Huawei and you haven't enabled background tasks for Nextcloud app?

@xXSTrikeXx

This comment has been minimized.

Copy link
Contributor

xXSTrikeXx commented Feb 28, 2018

I have this problem not so often, but at least on one file. I'll keep an eye on it ;)

@tobiasKaminsky

This comment has been minimized.

Copy link
Member

tobiasKaminsky commented Mar 1, 2018

Does a manual restart on the failed upload in the upload view is working?
In other words: the file is correctly queued in uploads by auto upload? Then the work of auto upload is indeed done and it "should" be the same as a normal upload.

@pixiandreas

This comment has been minimized.

Copy link

pixiandreas commented Mar 1, 2018

Hello
Same problem here
Samsung S7 with nextcloud 3.0.2

Before the app update 2018-02-28 everything works as it should.
But the manual update and Web works but not the autoupload
The error message is "Could no complete operation. Server unavailable"

I have try to restart the server and the app but still the same error.

Andreas H

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

I am seeing this exact same problem with a Galaxy S6.

The uploads still fail if you manually click to retry but a 'normal' manual upload works fine.

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

I've got what looks like a relevant snippet from the client log file (nothing seems to happen on the server though I could be missing something)

2018/03/01 09:18:58
UploadsStorageManager : Updating /storage/emulated/0/DCIM/Camera/20180301_090234.jpg with status=UPLOAD_IN_PROGRESS

2018/03/01 09:18:58
UploadsStorageManager : updateUpload returns with: 1 for file: /storage/emulated/0/DCIM/Camera/20180301_090234.jpg

2018/03/01 09:18:58
UploadsStorageManager : notifyObserversNow

2018/03/01 09:18:58
FileUploader : Error uploading Exception : [com.owncloud.android.operations.UploadFileOperation.run(UploadFileOperation.java:374), com.owncloud.android.lib.common.operations.RemoteOperation.execute(RemoteOperation.java:145), com.owncloud.android.lib.common.operations.RemoteOperation.execute(RemoteOperation.java:149), com.owncloud.android.operations.common.SyncOperation.execute(SyncOperation.java:93), com.owncloud.android.files.services.FileUploader.uploadFile(FileUploader.java:1090), com.owncloud.android.files.services.FileUploader$ServiceHandler.handleMessage(FileUploader.java:1023), android.os.Handler.dispatchMessage(Handler.java:102), android.os.Looper.loop(Looper.java:154), android.os.HandlerThread.run(HandlerThread.java:61)]

2018/03/01 09:18:58
UploadsStorageManager : updateDatabaseUploadResult uploadResult: com.owncloud.android.lib.common.operations.RemoteOperationResult@ad925c2 upload: com.owncloud.android.operations.UploadFileOperation@e025fd3

2018/03/01 09:18:58
UploadsStorageManager : Updating /storage/emulated/0/DCIM/Camera/20180301_090234.jpg with status:UPLOAD_FAILED and result:NETWORK_CONNECTION (old:/storage/emulated/0/DCIM/Camera/20180301_090234.jpg status:UPLOAD_IN_PROGRESS result:-1)]
Does this help any?

@jospoortvliet

This comment has been minimized.

Copy link
Member

jospoortvliet commented Mar 1, 2018

@mario my galaxy S7 also gives 'server unavailable' and that is using cloud.nextcloud.com for testing ;-) ping me if you need me to test/check anything.

@rikmeijer

This comment has been minimized.

Copy link

rikmeijer commented Mar 1, 2018

Having the same problem, although nothing relevant appears in my log files

EDIT copied report from #2261:
Actual behaviour

-Take picture

wait for nextcloud
see error "Could not complete operation. Server unavailable" appear

Normal uploads do work!!

Apparently a HOST_NOT_AVAILABLE result is being returned, but I am unable to determine if this is caused by an InvalidHostException or a RuntimeException. I suspect a RuntimeException, but am unable to debug any further.
Expected behaviour

Automatic uploads should upload *they did up until yesterday".

Steps to reproduce

see actual behaviour

Environment data

Android version: 7.1.2

Device model: Wileyfox Swift 2 Plus

Stock or customized system: stock

Nextcloud app version: 3.0.2

Nextcloud server version: 13.0.0
Logs
Web server error log

nothing appears in server log

Nextcloud log (data/nextcloud.log)

nothing appears in nextcloud log

NOTE: Be super sure to remove sensitive data like passwords, note that everybody can look here! You can use the Issue Template application to prefill some of the required information: https://apps.nextcloud.com/apps/issuetemplate

@AndyScherzinger AndyScherzinger added the high label Mar 1, 2018

@digorgonzola

This comment has been minimized.

Copy link

digorgonzola commented Mar 1, 2018

Same issue here on a MotoG but the following seemed to fix it.

Uploaded two files manually: worked a treat

Went back to the upload queue and retried failed uploads. New message "waiting to exit powersave mode" (just happened to have pretty low battery).

Plugged in charger and hey presto it worked!

Took some more photos just to make sure it wasn't a fluke and it did work.

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

The message for me has always been "Failed/pending restart".

Plugging in the power cable made no difference.

@mario

This comment has been minimized.

Copy link
Member

mario commented Mar 1, 2018

So auto upload has two jobs:

  • schedule upload
  • auto-retry

It looks like that parts are working.

Then it performs regular upload, so did you all try (including @jospoortvliet) if regular upload is working? Maybe related to agent changes @tobiasKaminsky ?

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

Yes, regular file upload works fine.

@rikmeijer

This comment has been minimized.

Copy link

rikmeijer commented Mar 1, 2018

@mario Yes, regular uploads work

@FoXFTW

This comment has been minimized.

Copy link

FoXFTW commented Mar 1, 2018

Having the same problem.
Device: Galaxy S8
Version: 3.0.2

Manual Upload works fine

@wvxx

This comment has been minimized.

Copy link

wvxx commented Mar 1, 2018

Same issue since yesterday's update.
Device: Xiaomi Mi 5
Version: 3.0.2

Tested as well on Huawei Mediapad x2 - same issue
Manual upload works in both cases.

@tobiasKaminsky

This comment has been minimized.

Copy link
Member

tobiasKaminsky commented Mar 1, 2018

Is manually resuming a broken, scheduled by auto upload, one working?
(I tried it with 3.0.2, and NC13 and it is working).

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

No, manually retrying the upload fails.

Also 3.0.2 and NC13

@wvxx

This comment has been minimized.

Copy link

wvxx commented Mar 1, 2018

In my case it doesn't even look like it's retrying anything. Progress bar pops up for literally a few miliseconds, then the same error comes back.

@jaark

This comment has been minimized.

Copy link

jaark commented Mar 1, 2018

Mine seems just like the above, I do not notice anything in the Apache logs when retrying the upload either..

@ghost

This comment has been minimized.

Copy link

ghost commented Mar 1, 2018

Same here with Android 6 device with 3.0.2 client.

I tried the Force rescan (German: Neuen Scan erzwingen) menu entry within Uploads and it seems that Auto Upload of new files (Screenshots) works now.

I'll keep an eye on it. But I made a restart of the device afterwards and I'm not sure whether it triggered the upload -- rescan or restart or both.

@tmechen

This comment has been minimized.

Copy link

tmechen commented Mar 1, 2018

Having this issue too since yesterday.
Xiaomi Mi 5
Nextcloud App 3.0.2

"Upload failed. Could not complete poeration. Server unavailabe"
while everything manually works (checking directories, downloading/ uploading files)
manual restart in the Auto Upload Menu does not work too.

@wvxx

This comment has been minimized.

Copy link

wvxx commented Mar 1, 2018

Force rescan does not work for me, sadly.

@HardcoreWR

This comment has been minimized.

Copy link

HardcoreWR commented Mar 1, 2018

Unfortunately both my wife and me have the exact same issue.
Manual upload works, but auto upload schedules the files to be uploaded but all fail with 'Connection error'

My phone: Galaxy S8
Nextcloud app version: 3.0.2

Wife's phone: Galaxy A5 (2017)
Nextcloud app version: 3.0.2

@Layiap

This comment has been minimized.

Copy link

Layiap commented Mar 1, 2018

Same problem here.
Galaxy S8
Android 8.0.0
Nextcloud app version: 3.0.2
Server v 13.0.0

@lukas2511

This comment has been minimized.

Copy link

lukas2511 commented Mar 1, 2018

Same here.
OnePlus 5T
Android 8.0.0
Nextcloud app version: 3.0.2
Server v 13.0.0

@cmot-weasel

This comment has been minimized.

Copy link

cmot-weasel commented Mar 1, 2018

Same here on two different Nextcloud server instances:

Personal setup:

  • Nextcloud Server v13.0.0 (just upgraded, same effect on 12.0.4, 12.0.5)
  • 2x Huawei P10 (both Android 7.0)
  • App version 3.0.2

Work Setup:

  • Nextcloud server v13.0.0
  • multiple Samsung Xcover 3 (Android 5.1.1)
  • App version 3.0.2

Summary:

  • Manual "upload file" works fine
  • Auto-upload fails with "Connection Error", manual restart fails
  • No logs in Nextcloud app on any device (in expert mode)
  • No logs on either server at all (web server or nextcloud.log)
  • No affect by removing/readding accounts on app, by clearing app data or reinstalling app.
@makeworld-the-better-one

This comment has been minimized.

Copy link

makeworld-the-better-one commented Apr 18, 2018

@jult so I downloaded a new file to a folder setup to be auto synced, and that file started syncing, but all the files that were in those folders before nextcloud did not sync. Any ideas about that? Also, how do I purge all app data? I can try and do that and then reinstall and see what happens.

@chefboyct

This comment has been minimized.

Copy link

chefboyct commented Apr 19, 2018

@AndyScherzinger Hi Andy, sorry random question as I cannot seem to find this topic at all under the main discussion and I cannot seem to message you in PRV. I have a quick question as I dust off my old Nokia 1020 (Windows 10 mobile) as I want to use the Nextcloud app to upload pictures to the nextcloud server but I am unsure what Nextcloud windows mobile support or not.. (trial version can only access files and have no options at all to auto upload). Can you help me to understand and verify this ? and if not, can I use owncloud application for Windows 10 mobile to auto upload? Thanks mate!

@AndyScherzinger

This comment has been minimized.

Copy link
Member

AndyScherzinger commented Apr 19, 2018

@chefboyct don't know really, I just use the Android and iOS apps don't know about the WindMobile capabilities or the oC windows mobile client's features.

@chefboyct

This comment has been minimized.

Copy link

chefboyct commented Apr 19, 2018

Thanks @AndyScherzinger I want to know but its fine. I can always manually upload them

@butterbrot21

This comment has been minimized.

Copy link

butterbrot21 commented Jun 29, 2018

Same here.
OnePlus 3T
Android 8.0.0
Nextcloud app version: 3.2.0
Server 13.0.4

@alaunay

This comment has been minimized.

Copy link

alaunay commented Jul 15, 2018

Same here, Galaxy S9+, app 3.2.1, server 13.0.2. I wonder if there's not something wrong with ipv6.

@jospoortvliet

This comment has been minimized.

Copy link
Member

jospoortvliet commented Aug 10, 2018

@makeworld-the-better-one you can do a re-scan of all files.

@jspearo

This comment has been minimized.

Copy link

jspearo commented Aug 15, 2018

How can I do a re-scan?
My instant upload works accidentaly, sometimes some files are uploaded... but usually not. And e.g. for Conversations (jabber) app images are usually uploaded, but when I take screeshot, usually not.
Samsung Galaxy S9+ ,Android version 8.0.0, Nextcloud Android app version 3.2.1, Nextcloud version 12.0.7.

@Joshndroid

This comment has been minimized.

Copy link

Joshndroid commented Aug 21, 2018

I can also confirm that setup with a Moto G5 plus that auto upload of images are not working. highly frustrating.

@Oxyaxion

This comment has been minimized.

Copy link

Oxyaxion commented Sep 3, 2018

Hi,
Same problem for me here. All was working fine before the last Nextcloud Android client update. I use an Honor 9 Lite and Android 8.

Now the automatic sync doesn't want working. I need to push manually all. And sometimes I have some connection problem (I need often to repush my password in the app).

That's bad :(

@kasumiru

This comment has been minimized.

Copy link

kasumiru commented Sep 6, 2018

I had the same problem. Manual upload works, but auto upload work not. Lg g5, android 7.0, Nextcloud v 12.

@bjschuit

This comment has been minimized.

Copy link

bjschuit commented Sep 8, 2018

Still an issue. Not always auto upload works. My phone, despite disabling power optimization for Nextcloud, sometimes terminates the app, causing upload failures. Other times it won't initiate. And sometimes it does initiate and starts uploading, but in the end not all of my pictures are uploaded, making this feature completely untrustworthy unfortunately.

@feutl

This comment has been minimized.

Copy link

feutl commented Sep 10, 2018

Using a Galaxy S9 and some pictures end up in the upload queue and some not. I have not figured out which an why, but it worked for some time without problems. started to make problems yesterday.

Even a "force rescan" does not place them in the queue.

I am not having nextcloud background sync activated because it drains 30% of the battery on its own.
Using the lates 13 server version and latest android version from the play store.

@feutl

This comment has been minimized.

Copy link

feutl commented Sep 11, 2018

hmm, but this also means, that the pictures not being uploaded yet are not getting uploaded as well. because we start over again.
This also implies that I do not really know which pictures are missing right now, because it just uploaded some picked them randomly and I have no clue which ones if I do not compare them by hand.

Not really a solution I would say, more a "dirty" workaround.
Especially because it worked at the beginning but for whatever reason stopped partially on the weekend.

Sth to note, all the steps you described in your post, I did at the very beginning of getting my s9+. Install the app, only the stock gallery app in use and but nextcloud to the "non-standby apps" but still I am now in the situation pictures do not get uploaded any more. I did at the beginning but after some weeks and around 50 pics it stopped working.

@rwat1

This comment has been minimized.

Copy link

rwat1 commented Sep 11, 2018

@feutl

This also implies that I do not really know which pictures are missing right now, because it just uploaded some picked them randomly and I have no clue which ones if I do not compare them by hand.

To make it easy, what I did was delete the most recently 50-70 photos on server (depends how long it stopped working) then manually reupload these from phone. It's more clicking, but alteast you ensure you uploaded everything recently.

Sth to note, all the steps you described in your post, I did at the very beginning of getting my s9+. Install the app, only the stock gallery app in use and but nextcloud to the "non-standby apps" but still I am now in the situation pictures do not get uploaded any more. I did at the beginning but after some weeks and around 50 pics it stopped working.

Are you me? This is exactly what happened to me too, I applied #2834 (comment) fix when I got my S9+, it worked very well. However... few weeks later, same autoupload problem. I had to apply the fix again. LOL, now it works very well.

I think it must be data configuration settings gets corrupted or de-linked whenever there is an Android security update. So expect that perhaps some future Android update involving security might affect the data configuration settings on NC app.

@jult

This comment has been minimized.

Copy link

jult commented Sep 11, 2018

FYI; I've stopped using this app because it just fails precisely when I don't want it to.
Started using app called FolderSync using WebDAV instead with my nextcloud server. Works fine. Even tempted to buy the pro version.

@feutl

This comment has been minimized.

Copy link

feutl commented Sep 12, 2018

@jult
I looked at FolderSync but it is not actively developed since a long time, which the maintainer also explains (https://plus.google.com/+AndersCarlsen/posts/5jVkiakqcFv)
This is not an option for me, if something is not getting developed any more, for whatever reason

@rwat1
I think I figured it out, for me at least.
I looked at all the devices I have with nextcloud auto upload activated. This are 6 devices all of the work except mine. They are different brands, different android version, Some older some newer, some from SD card some sync from internal storage.
The only thing that popped was SD card encryption

Mine was the only one having SD card encryption turned on and stores the pictures on the external SD card. I turned that off, and after completing Nextcloud started to resync the pictures I was missing. It did not resync the pics between the problem appeared and I tried stuff and did pictures and turning of SD card encryption, but the ones I was missing from the weekend where Nextcloud just uploaded some but not all.
AND it is also uploading all pics I did since turning it off without problems.

The question is, could it be that SD card encryption also comes into your way?
If yes, try turning it off, I know not very "secure" but so we could just pinpoint the issue ;) because your solution just is not a solution at all.

@powerriegel

This comment has been minimized.

Copy link

powerriegel commented Oct 12, 2018

Same problem here. Auto Upload does not recognize that I've taken a picture. Huawei Mate 10 Pro. Manual upload works fine.

@xXSTrikeXx

This comment has been minimized.

Copy link
Contributor

xXSTrikeXx commented Oct 14, 2018

@powerriegel AFAIK the autouloader checks every 15 minutes for new files to prevent battery drain. Please recheck your device behavior with this knowlege 😉

@Shucach

This comment has been minimized.

Copy link

Shucach commented Oct 15, 2018

I have same problem. In meizu m2 mini. Auto loader doesn't work. Manual upload works.

@powerriegel

This comment has been minimized.

Copy link

powerriegel commented Oct 15, 2018

@xXSTrikeXx it never uploads anything automatically. I took a picture two days ago and its not uploaded until now.

@rwat1

This comment has been minimized.

Copy link

rwat1 commented Oct 15, 2018

@powerriegel @Shucach

This worked on my phone and helped many people too:

#2834 (comment)

I can upload flawlessly

@powerriegel

This comment has been minimized.

Copy link

powerriegel commented Oct 16, 2018

Hello, I got it working on Huawei Mate 10 Pro

  • Cleaned Cache
  • Added Nextcloud to Ignore power optimization list
  • Locked Nextcloud app (press the square symbol and then the locker). Then NC will always reside in memory.
  • Took a photo - immediatelly uploaded.

Huawei does lots of modifications on basic Android thats why I don't get any notifications (AirBnB, eBay). Buts it's really crap that users need to add apps to lists to get them working.

@Mebus

This comment has been minimized.

Copy link

Mebus commented Oct 28, 2018

Hallo,

I have got the same problem on a LG G3 since a few weeks, Android Version 6.0. I can upload files manually, but uploading files automatically doesn't work, even if you try to force the app to retry the upload.

I think the solution, which powerriegel described is only a workaround and doesn't fix the issue.

Can someone please reopen the ticket?

Mebus

@rwat1

This comment has been minimized.

Copy link

rwat1 commented Oct 29, 2018

@Mebus

Have you tried my solution? It fixed my problem and many other people's problem. It's been working for 3 months so far, no problem for me :) upload super fast.

#2834 (comment)

@phi-el

This comment has been minimized.

Copy link

phi-el commented Jan 13, 2019

Hi,

same Problem on a Sony Xperia XZ2 w/ 3.4.1 where auto upload is also allowed via 4G. Photo automatically uploads when there is no WiFi, but does not automatically starts when there is WiFi.
I'm not able to re-queue failed auto uploads w/ force sync.
The same behavior has been watched on a Samsung J5, but the forced sync uploads the missing photos.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment