New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

X-XSS-Protection header invalid (NextCloud 12.0.0.29) #5102

Closed
ghost opened this Issue May 24, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@ghost

ghost commented May 24, 2017

.htaccess contains:

Header set X-XSS-Protection "1; mode=block"

which is not valid. Chrome and probably some others (i used Chrome 58.0.3029.110) report semicolon is missing. have to be:

Header set X-XSS-Protection "1; mode=block;"

@LukasReschke

This comment has been minimized.

Show comment
Hide comment
@LukasReschke

LukasReschke Jul 24, 2017

Member

As per https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-XSS-Protection this seems to be correct without ; at the end and I also don't get the error. Are you sure it's not a plugin messing around?

Member

LukasReschke commented Jul 24, 2017

As per https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-XSS-Protection this seems to be correct without ; at the end and I also don't get the error. Are you sure it's not a plugin messing around?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment