Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Security] Bump handlebars from 4.0.12 to 4.1.0 in /build #14187

Merged
merged 1 commit into from Feb 14, 2019

Conversation

Projects
None yet
2 participants
@dependabot
Copy link
Contributor

dependabot bot commented Feb 14, 2019

Bumps handlebars from 4.0.12 to 4.1.0. This update includes security fixes.

Vulnerabilities fixed

Sourced from The npm Advisory Database.

Prototype Pollusion
All versions of handlebars are vulnerable to Prototype Pollusion. Templates may alter an Objects' prototype, thus allowing an attacker to execute arbitrary code on the server.

Affected versions: <=4.0.12

Changelog

Sourced from handlebars's changelog.

v4.1.0 - February 7th, 2019

New Features

  • import TypeScript typings - 27ac1ee

Security fixes:

  • disallow access to the constructor in templates to prevent RCE - 42841c4, #1495

Housekeeping

  • chore: fix components/handlebars package.json and auto-update on release - bacd473
  • chore: Use node 10 to build handlebars - 78dd89c
  • chore/doc: Add more release docs - 6b87c21

Compatibility notes:

Access to class constructors (i.e. ({}).constructor) is now prohibited to prevent
Remote Code Execution. This means that following construct will no work anymore:

class SomeClass {
}

SomeClass.staticProperty = 'static'

var template = Handlebars.compile('{{constructor.staticProperty}}');
document.getElementById('output').innerHTML = template(new SomeClass());
// expected: 'static', but now this is empty.

This kind of access is not the intended use of Handlebars and leads to the vulnerability described in #1495. We will not increase the major version, because such use is not intended or documented, and because of the potential impact of the issue (we fear that most people won't use a new major version and the issue may not be resolved on many systems).

Commits

Commits
  • 7caca94 v4.1.0
  • 7bd34fb Update release notes
  • 56fc676 test: run appveyor tests in Node 10
  • ee30222 chore: disable sauce-labs
  • 05e6293 chore: bump version of grunt-saucelabs
  • 2db0d12 chore: add .idea and yarn-error.log to .gitignore
  • edc6220 fix: disallow access to the constructor in templates to prevent RCE
  • bacd473 chore: fix components/handlebars package.json and auto-update on release
  • 27ac1ee Feat: Import TypeScript typings
  • 78dd89c chore: Use node 10 to build handlebars
  • Additional commits viewable in compare view

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

You can always request more updates by clicking Bump now in your Dependabot dashboard.

Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

Finally, you can contact us by mentioning @dependabot.

[Security] Bump handlebars from 4.0.12 to 4.1.0 in /build
Bumps [handlebars](https://github.com/wycats/handlebars.js) from 4.0.12 to 4.1.0. **This update includes security fixes.**
- [Release notes](https://github.com/wycats/handlebars.js/releases)
- [Changelog](https://github.com/wycats/handlebars.js/blob/v4.1.0/release-notes.md)
- [Commits](wycats/handlebars.js@v4.0.12...v4.1.0)

Signed-off-by: dependabot[bot] <support@dependabot.com>

@rullzer rullzer merged commit 98e18ad into stable15 Feb 14, 2019

1 check failed

continuous-integration/drone/pr the build failed
Details

@rullzer rullzer deleted the dependabot/npm_and_yarn/build/stable15/handlebars-4.1.0 branch Feb 14, 2019

@MorrisJobke MorrisJobke referenced this pull request Feb 20, 2019

Merged

15.0.5 RC 1 #14304

4 of 4 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.