Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

updater forces me to update to 13.0 instead of 12.0.5 #159

Closed
tessus opened this issue Mar 11, 2018 · 6 comments
Closed

updater forces me to update to 13.0 instead of 12.0.5 #159

tessus opened this issue Mar 11, 2018 · 6 comments

Comments

@tessus
Copy link
Contributor

@tessus tessus commented Mar 11, 2018

I'm currently running 12.0.4 and want to update to 12.0.5.

The updater app (web, command line) forces me to update to 13.0. However, I don't feel comfortable to do so yet.

Is there a way to convince the updater to only update within a release?

@tessus tessus changed the title updater forces my to update to 13.0 instead of 12.0.5 updater forces me to update to 13.0 instead of 12.0.5 Mar 11, 2018
@MorrisJobke

This comment has been minimized.

Copy link
Member

@MorrisJobke MorrisJobke commented Mar 12, 2018

Is there a way to convince the updater to only update within a release?

Use the production channel instead of the stable channel. Production channel receives the updates to the next major version a bit later (with the .1 or .2 release - depending on the feedback we get from users).

@tessus

This comment has been minimized.

Copy link
Contributor Author

@tessus tessus commented Mar 13, 2018

Thank you for the reply.

Use the production channel instead of the stable channel.

This seems like a valid workaround currently, but it won't help me as soon as the production channel switches as well.

Is there any chance you guys could create a Release channel for which the updater only considers the point updates for the installed release?

@MorrisJobke

This comment has been minimized.

Copy link
Member

@MorrisJobke MorrisJobke commented Mar 13, 2018

Is there any chance you guys could create a Release channel for which the updater only considers the point updates for the installed release?

Could I ask for the use case first to check what we missed here. Usually we try to get instances upgraded as soon as possible and thus provide the somehow delayed production channel. At some point the old releases are EoL and updating then should only be the last resort.

@tessus

This comment has been minimized.

Copy link
Contributor Author

@tessus tessus commented Mar 13, 2018

I'm often very reluctant to install a new release. The last 2 major .0 releases had a few severe bugs which would have made my nextcloud instance pretty much unusable.

I'm not saying that I do not want to upgrade, but I might want to wait longer than .1 or .2.

It should be my choice, or at least I should have the option to choose. But you basically force people to upgrade, which is not a very good stategy. All I am saying is that you should give people a choice.

I will most likely upgrade to 13.3 or 13.4, but in the meantime I would still like to update my nc 12 to the latest point release, which I cannot do, as soon as the Production channel switches over. But this is your decision, not mine, while in a real admin scenario it should be mine.

@MorrisJobke

This comment has been minimized.

Copy link
Member

@MorrisJobke MorrisJobke commented Mar 13, 2018

As this needs to be put into the server I opened a ticket for this: nextcloud/server#8799

@tessus

This comment has been minimized.

Copy link
Contributor Author

@tessus tessus commented Mar 13, 2018

Thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.