Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Propose a Symfony recipe #25

Open
soullivaneuh opened this issue Jan 18, 2018 · 3 comments
Open

Propose a Symfony recipe #25

soullivaneuh opened this issue Jan 18, 2018 · 3 comments

Comments

@soullivaneuh
Copy link
Member

@soullivaneuh soullivaneuh commented Jan 18, 2018

With default configuration (endpoint).

@bocharsky-bw
Copy link
Contributor

@bocharsky-bw bocharsky-bw commented Jan 22, 2020

I think the recipe is really needed. I cannot install this bundle without recipe:

composer require nexylan/slack-bundle php-http/guzzle6-adapter

Using version ^2.2 for nexylan/slack-bundle
Using version ^2.0 for php-http/guzzle6-adapter
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Restricting packages listed in "symfony/symfony" to "5.0.*"

Prefetching 44 packages 🎵 💨
  - Downloading (100%)

Package operations: 27 installs, 84 updates, 11 removals
  - Removing symfony/polyfill-iconv (v1.12.0)
  - Removing symfony/debug (v4.3.8)
  - Removing swiftmailer/swiftmailer (v6.2.1)
  - Removing composer/ca-bundle (1.2.3)
  - Removing doctrine/doctrine-cache-bundle (1.3.5)
  - Removing symfony/swiftmailer-bundle (v3.2.8)
  - Removing symfony/polyfill-php72 (v1.12.0)
  - Removing symfony/polyfill-php70 (v1.12.0)
  - Removing twig/extensions (v1.5.4)
  - Removing symfony/web-server-bundle (v4.3.3)
  - Removing sensiolabs/security-checker (v5.0.3)
  - Updating ocramius/package-versions (1.4.0 => 1.4.2): Loading from cache
  - Updating symfony/flex (v1.4.5 => v1.5.3): Loading from cache
  - Updating symfony/service-contracts (v1.1.8 => v2.0.1): Loading from cache
  - Updating symfony/stopwatch (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/polyfill-php73 (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/polyfill-mbstring (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/console (v4.3.3 => v5.0.1): Loading from cache
  - Updating zendframework/zend-code (3.3.1 => 3.4.0): Loading from cache
  - Updating ocramius/proxy-manager (2.1.1 => 2.2.3): Loading from cache
  - Updating doctrine/event-manager (v1.0.0 => 1.1.0): Loading from cache
  - Updating doctrine/cache (v1.8.0 => 1.10.0): Loading from cache
  - Updating doctrine/dbal (v2.9.2 => v2.10.0): Loading from cache
  - Updating doctrine/migrations (v1.8.1 => 2.2.0): Loading from cache
  - Updating symfony/routing (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/polyfill-ctype (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/polyfill-intl-idn (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/mime (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/http-foundation (v4.3.8 => v5.0.2): Loading from cache
  - Installing psr/event-dispatcher (1.0.0): Loading from cache
  - Updating symfony/event-dispatcher-contracts (v1.1.7 => v2.0.1): Loading from cache
  - Updating symfony/event-dispatcher (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/var-dumper (v4.3.3 => v5.0.2): Loading from cache
  - Installing symfony/error-handler (v5.0.2): Loading from cache
  - Updating symfony/http-kernel (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/finder (v4.3.8 => v5.0.1): Loading from cache
  - Updating symfony/filesystem (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/dependency-injection (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/config (v4.3.8 => v5.0.2): Loading from cache
  - Updating symfony/var-exporter (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/cache-contracts (v1.1.5 => v2.0.1): Loading from cache
  - Updating symfony/cache (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/framework-bundle (v4.3.3 => v5.0.1): Loading from cache
  - Updating doctrine/lexer (1.0.2 => 1.2.0): Loading from cache
  - Updating doctrine/annotations (v1.7.0 => v1.8.0): Loading from cache
  - Updating doctrine/collections (v1.6.2 => 1.6.4): Loading from cache
  - Updating doctrine/persistence (1.1.1 => 1.2.0): Loading from cache
  - Updating symfony/doctrine-bridge (v4.3.3 => v5.0.1): Loading from cache
  - Updating doctrine/doctrine-bundle (1.11.2 => 2.0.2): Loading from cache
  - Updating symfony/security-core (v4.3.3 => v5.0.1): Loading from cache
  - Updating doctrine/common (v2.10.0 => v2.11.0): Loading from cache
  - Updating doctrine/doctrine-migrations-bundle (v1.3.2 => 2.1.2): Loading from cache
  - Updating sensio/framework-extra-bundle (v5.4.1 => v5.5.1): Loading from cache
  - Updating symfony/dotenv (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/expression-language (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/inflector (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/property-access (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/options-resolver (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/polyfill-intl-icu (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/intl (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/form (v4.3.3 => v5.0.1): Loading from cache
  - Updating monolog/monolog (1.24.0 => 2.0.1): Loading from cache
  - Updating symfony/monolog-bridge (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/monolog-bundle (v3.4.0 => v3.5.0): Loading from cache
  - Updating symfony/polyfill-intl-messageformatter (v1.12.0 => v1.13.1): Loading from cache
  - Updating symfony/security-http (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/security-guard (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/security-csrf (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/security-bundle (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/translation-contracts (v1.1.5 => v2.0.1): Loading from cache
  - Updating symfony/translation (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/validator (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/asset (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/webpack-encore-bundle (v1.6.2 => v1.7.2): Loading from cache
  - Updating symfony/yaml (v4.3.3 => v5.0.1): Loading from cache
  - Updating tgalopin/html-sanitizer (1.2.0 => 1.3.0): Loading from cache
  - Updating tgalopin/html-sanitizer-bundle (1.1.3 => 1.2.0): Loading from cache
  - Updating dama/doctrine-test-bundle (v5.0.3 => v6.2.1): Loading from cache
  - Updating doctrine/instantiator (1.2.0 => 1.3.0): Loading from cache
  - Updating doctrine/orm (v2.6.3 => v2.7.0): Loading from cache
  - Updating doctrine/data-fixtures (v1.3.2 => 1.4.0): Loading from cache
  - Updating doctrine/doctrine-fixtures-bundle (3.2.2 => 3.3.0): Loading from cache
  - Updating symfony/process (v4.3.3 => v5.0.1): Loading from cache
  - Updating composer/xdebug-handler (1.3.3 => 1.4.0): Loading from cache
  - Updating php-cs-fixer/diff (v1.3.0 => v2.0.1): Loading from cache
  - Removing friendsofphp/php-cs-fixer (v2.15.1)
  - Installing friendsofphp/php-cs-fixer (3.0.x-dev a397617): Loading from cache
  - Updating symfony/dom-crawler (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/browser-kit (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/css-selector (v4.3.3 => v5.0.1): Loading from cache
  - Updating twig/twig (v2.11.3 => v3.0.0): Loading from cache
  - Updating symfony/twig-bridge (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/debug-bundle (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/maker-bundle (dev-feat-forgotten-password 542591c => v1.14.3):  Checking out c864e7f9b8
  - Updating symfony/phpunit-bridge (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/twig-bundle (v4.3.3 => v5.0.1): Loading from cache
  - Updating symfony/web-profiler-bundle (v4.3.3 => v5.0.1): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing clue/stream-filter (v1.4.1): Loading from cache
  - Installing php-http/message-factory (v1.0.2): Loading from cache
  - Installing php-http/message (1.8.0): Loading from cache
  - Installing php-http/promise (v1.0.0): Loading from cache
  - Installing psr/http-client (1.0.0): Loading from cache
  - Installing php-http/httplug (2.1.0): Loading from cache
  - Installing php-http/client-common (2.1.0): Loading from cache
  - Installing php-http/stopwatch-plugin (1.3.0): Loading from cache
  - Installing php-http/logger-plugin (1.1.0): Loading from cache
  - Installing php-http/discovery (1.7.4): Loading from cache
  - Installing ralouphie/getallheaders (3.0.3): Loading from cache
  - Installing guzzlehttp/psr7 (1.6.1): Loading from cache
  - Installing guzzlehttp/promises (v1.3.1): Loading from cache
  - Installing guzzlehttp/guzzle (6.5.2): Loading from cache
  - Installing php-http/guzzle6-adapter (v2.0.1): Loading from cache
  - Installing php-http/httplug-bundle (1.17.0): Loading from cache
  - Installing psr/http-factory (1.0.1): Loading from cache
  - Installing nexylan/slack (v3.0.0): Loading from cache
  - Installing nexylan/slack-bundle (v2.2.1): Loading from cache
  - Updating egulias/email-validator (2.1.11 => 2.1.13): Loading from cache
  - Installing symfony/mailer (v5.0.2): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.13.1): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.13.1): Loading from cache
  - Installing symfony/string (v5.0.1): Loading from cache
  - Installing twig/intl-extra (v3.0.0): Loading from cache
Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.
Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.
Writing lock file
Generating autoload files
Symfony operations: 2 recipes (9509902ed45abcfcad5abbc90808c31c)
  - Configuring php-http/httplug-bundle (>=1.6): From github.com/symfony/recipes-contrib:master
  - Configuring nexylan/slack-bundle (>=v2.2.1): From auto-generated recipe
ocramius/package-versions:  Generating version class...
ocramius/package-versions: ...done generating version class
Executing script cache:clear [KO]
 [KO]
Script cache:clear returned with error code 1
!!
!!  In ArrayNode.php line 216:
!!
!!    The child node "endpoint" at path "nexy_slack" must be configured.
!!
!!
!!
Script @auto-scripts was called via post-update-cmd

Installation failed, reverting ./composer.json to its original content.

So, it just reverts my composer.json

@soullivaneuh
Copy link
Member Author

@soullivaneuh soullivaneuh commented Jan 31, 2020

The flex recipe is a good idea for comfort, but you can use this bundle without flex.

Just create a configuration file with the required field.

See also: https://github.com/nexylan/slack-bundle#configuration

@bocharsky-bw
Copy link
Contributor

@bocharsky-bw bocharsky-bw commented Feb 3, 2020

Yeah, I'm mostly about improving UX for those who use Symfony Flex here. Config section in README is pretty clear for me

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.