Permalink
Browse files

remove jeweler

  • Loading branch information...
1 parent beb3076 commit 50036e4c767e7c2107afb6fe57fde75b413b2eb8 @fb3 fb3 committed May 17, 2011
Showing with 7 additions and 57 deletions.
  1. +0 −16 Rakefile
  2. +1 −1 VERSION
  3. +6 −40 retryable.gemspec
View
16 Rakefile
@@ -11,22 +11,6 @@ rescue Bundler::BundlerError => e
end
require 'rake'
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- gem.name = "retryable"
- gem.homepage = "http://github.com/nfedyashev/retryable"
- gem.license = "MIT"
- gem.summary = %Q{Kernel#retryable, allow for retrying of code blocks.}
- gem.description = %Q{Kernel#retryable, allow for retrying of code blocks.}
- gem.email = "loci.master@gmail.com"
- gem.authors = ["Nikita Fedyashev", "Carlo Zottmann", "Chu Yeow"]
-
- gem.add_development_dependency 'bundler', ['>= 1.0.0']
- gem.add_development_dependency 'rspec', '~> 2.5.0'
-
-end
-Jeweler::RubygemsDotOrgTasks.new
-
require 'rspec/core'
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec)
View
2 VERSION
@@ -1 +1 @@
-1.2.2
+1.2.3
View
46 retryable.gemspec
@@ -5,58 +5,24 @@
Gem::Specification.new do |s|
s.name = %q{retryable}
- s.version = "1.2.2"
+ s.version = "1.2.3"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Nikita Fedyashev", "Carlo Zottmann", "Chu Yeow"]
- s.date = %q{2011-05-10}
+ s.date = %q{2011-05-16}
s.description = %q{Kernel#retryable, allow for retrying of code blocks.}
s.email = %q{loci.master@gmail.com}
s.extra_rdoc_files = [
"README.markdown"
]
- s.files = [
- ".travis.yml",
- "Gemfile",
- "README.markdown",
- "Rakefile",
- "VERSION",
- "lib/retryable.rb",
- "retryable.gemspec",
- "spec/lib/retryable_spec.rb",
- "spec/spec_helper.rb"
- ]
+ s.files = `git ls-files lib`.split("\n")
s.homepage = %q{http://github.com/nfedyashev/retryable}
s.licenses = ["MIT"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.7.1}
s.summary = %q{Kernel#retryable, allow for retrying of code blocks.}
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.add_development_dependency('rspec', '~> 2.5.0')
+ s.add_development_dependency('bundler')
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<retryable>, [">= 0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.0"])
- s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
- s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
- else
- s.add_dependency(%q<retryable>, [">= 0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
- s.add_dependency(%q<rspec>, ["~> 2.5.0"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<rspec>, ["~> 2.5.0"])
- end
- else
- s.add_dependency(%q<retryable>, [">= 0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
- s.add_dependency(%q<rspec>, ["~> 2.5.0"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<bundler>, [">= 1.0.0"])
- s.add_dependency(%q<rspec>, ["~> 2.5.0"])
- end
+ s.required_rubygems_version = '>= 1.3.6'
end

0 comments on commit 50036e4

Please sign in to comment.