Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Remove explicit yard version requirement

YARD seems fairly stable when it comes to this plugin, so we just
drop the '~>' requirement entirely.
  • Loading branch information...
commit 07930025d8b68cfac3b8a5fe6a7d09de39a7a926 1 parent 4ec2cdc
Nicos Gollan authored
View
8 Rakefile
@@ -10,10 +10,10 @@ begin
A plugin for the YARD documentation system that adds syntax highlighting
for a wide variety of languages using the Pygments highlighter.
DESC
- gem.email = "nex342@gmail.com"
- gem.homepage = "http://github.com/nex3/yard-pygments"
- gem.authors = ["Nathan Weizenbaum"]
- gem.add_dependency('yard', '~> 0.5.3')
+ gem.email = "gtdev@spearhead.de"
+ gem.homepage = "http://github.com/ngollan/yard-pygments"
+ gem.authors = ["Nathan Weizenbaum", "Nicos Gollan"]
+ gem.add_dependency('yard')
gem.add_dependency('rb-pygments', '>= 0.1.0')
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
View
2  VERSION
@@ -1 +1 @@
-0.1.1
+0.1.2
View
0  bin/.gitignore
No changes.
View
54 yard-pygments.gemspec
@@ -1,55 +1,49 @@
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{yard-pygments}
- s.version = "0.1.1"
+ s.name = "yard-pygments"
+ s.version = "0.1.2"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Nathan Weizenbaum"]
- s.date = %q{2010-01-24}
- s.description = %q{A plugin for the YARD documentation system that adds syntax highlighting
-for a wide variety of languages using the Pygments highlighter.
-}
- s.email = %q{nex342@gmail.com}
+ s.authors = ["Nathan Weizenbaum", "Nicos Gollan"]
+ s.date = "2012-03-26"
+ s.description = "A plugin for the YARD documentation system that adds syntax highlighting\nfor a wide variety of languages using the Pygments highlighter.\n"
+ s.email = "gtdev@spearhead.de"
s.extra_rdoc_files = [
"README.md"
]
s.files = [
- ".gitignore",
- ".yardopts",
- "MIT-LICENSE",
- "README.md",
- "Rakefile",
- "VERSION",
- "bin/.gitignore",
- "lib/yard-pygments.rb",
- "templates/default/fulldoc/html/pygments.erb",
- "templates/default/fulldoc/html/setup.rb",
- "templates/default/layout/html/headers.erb",
- "yard-pygments.gemspec"
+ ".yardopts",
+ "MIT-LICENSE",
+ "README.md",
+ "Rakefile",
+ "VERSION",
+ "lib/yard-pygments.rb",
+ "templates/default/fulldoc/html/pygments.erb",
+ "templates/default/fulldoc/html/setup.rb",
+ "templates/default/layout/html/headers.erb",
+ "yard-pygments.gemspec"
]
- s.homepage = %q{http://github.com/nex3/yard-pygments}
- s.rdoc_options = ["--charset=UTF-8"]
+ s.homepage = "http://github.com/ngollan/yard-pygments"
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
- s.summary = %q{Pygments-based syntax highlighting for YARD.}
+ s.rubygems_version = "1.8.19"
+ s.summary = "Pygments-based syntax highlighting for YARD."
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<yard>, ["~> 0.5.3"])
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<yard>, [">= 0"])
s.add_runtime_dependency(%q<rb-pygments>, [">= 0.1.0"])
else
- s.add_dependency(%q<yard>, ["~> 0.5.3"])
+ s.add_dependency(%q<yard>, [">= 0"])
s.add_dependency(%q<rb-pygments>, [">= 0.1.0"])
end
else
- s.add_dependency(%q<yard>, ["~> 0.5.3"])
+ s.add_dependency(%q<yard>, [">= 0"])
s.add_dependency(%q<rb-pygments>, [">= 0.1.0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.