Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

config files for Travis CI continuous integration service

  • Loading branch information...
commit 7e8153c09660c31d6286c1924680b8c5073a10b6 1 parent f1ecae7
@ngoto authored
View
73 .travis.yml
@@ -0,0 +1,73 @@
+language: ruby
+rvm:
+ - 1.9.3
+ - 1.9.2
+ - 1.8.7
+ - jruby-19mode # JRuby in 1.9 mode
+ - jruby-18mode # JRuby in 1.8 mode
+ - rbx-19mode
+ - rbx-18mode
+gemfile:
+ - gemfiles/Gemfile.travis-ruby1.9
+ - gemfiles/Gemfile.travis-ruby1.8
+ - gemfiles/Gemfile.travis-jruby1.9
+ - gemfiles/Gemfile.travis-jruby1.8
+matrix:
+ exclude:
+ - rvm: 1.8.7
+ gemfile: gemfiles/Gemfile.travis-ruby1.9
+ - rvm: 1.8.7
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: 1.8.7
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+ - rvm: jruby-18mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.8
+ - rvm: jruby-18mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.9
+ - rvm: jruby-18mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+ - rvm: rbx-18mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.9
+ - rvm: rbx-18mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: rbx-18mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+ - rvm: 1.9.2
+ gemfile: gemfiles/Gemfile.travis-ruby1.8
+ - rvm: 1.9.2
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: 1.9.2
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+ - rvm: 1.9.3
+ gemfile: gemfiles/Gemfile.travis-ruby1.8
+ - rvm: 1.9.3
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: 1.9.3
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+ - rvm: jruby-19mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.8
+ - rvm: jruby-19mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.9
+ - rvm: jruby-19mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: rbx-19mode
+ gemfile: gemfiles/Gemfile.travis-ruby1.8
+ - rvm: rbx-19mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.8
+ - rvm: rbx-19mode
+ gemfile: gemfiles/Gemfile.travis-jruby1.9
+
+# uncomment this line if your project needs to run something other than `rake`:
+# script: bundle exec rspec spec
+
+before_install:
+ - sudo apt-get update
+ - sudo apt-get install libxml2-dev libexpat1-dev
+after_install:
+ - rake regemspec
+
+# whitelist branches
+branches:
+ only:
+ - master
+
View
6 gemfiles/Gemfile.travis-jruby1.8
@@ -0,0 +1,6 @@
+source :rubygems
+
+gem "rake"
+
+gem "libxml-jruby"
+
View
7 gemfiles/Gemfile.travis-jruby1.9
@@ -0,0 +1,7 @@
+source :rubygems
+
+gem "rake"
+
+gem "libxml-jruby"
+gem "soap4r-ruby1.9"
+
View
7 gemfiles/Gemfile.travis-ruby1.8
@@ -0,0 +1,7 @@
+source :rubygems
+
+gem "rake"
+
+gem "xmlparser"
+gem "libxml-ruby"
+
View
8 gemfiles/Gemfile.travis-ruby1.9
@@ -0,0 +1,8 @@
+source :rubygems
+
+gem "rake"
+
+gem "xmlparser"
+gem "libxml-ruby"
+gem "soap4r-ruby1.9"
+
Please sign in to comment.
Something went wrong with that request. Please try again.