Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

not allowed to upload new version of my package #27

Open
ArneBab opened this issue Jun 20, 2014 · 31 comments

Comments

@ArneBab
Copy link

commented Jun 20, 2014

I just tried uploading a new wisp-mode.el, but got a bad request: not allowed error. I fear that I might have used a different username for uploading (I used ArneBab to login but the package^pkg lists my email address). My username^un also shows no contributed packages.

When trying to upload a new test-package, marmalade stalled until Firefox gave up.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Jun 22, 2014

Apologies for a tardy response I was away in India. I'll have a look this afternoon or over the next few days.

@ArneBab

This comment has been minimized.

Copy link
Author

commented Jun 22, 2014

no probs. Thank you for looking into it!

@rolandwalker

This comment has been minimized.

Copy link

commented Jul 8, 2014

I have the same issue with username roland.walker showing no packages.

Example package http://marmalade-repo.org/packages/ucs-utils will not allow a new version to be uploaded.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Jul 8, 2014

Thanks. It's probably linked to the partial failure of the original mongo-export. I am looking into it.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Jul 8, 2014

So, for some bizarre reason mongo has exported Roland's username as: "roland.walker"

I'm not sure what character that is and why it things fullstop is instead that. I can't see a reason why Arne's packages aren't listed for him.

@rolandwalker

This comment has been minimized.

Copy link

commented Jul 9, 2014

Thanks. That character is FULLWIDTH FULL STOP U+FF0E. I am not able to log in under the username with the weird character. Login for "roland.walker" is working fine.

@rolandwalker

This comment has been minimized.

Copy link

commented Jul 31, 2014

Still have the same issue. I can log in, but I cannot update libraries that belong to me. I guess they belong to "roland.walker". Can you just delete them? If so I can upload new copies under "roland.walker".

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Jul 31, 2014

Really sorry. Will fix it over the weekend.

@malroc

This comment has been minimized.

Copy link

commented Aug 23, 2014

Can't upload a new version of my package (most likely I have 2 different accounts and don't remember the credentials for the right one, and it looks like currently there is no way to restore login/password).
Could you please remove this package so I could upload a new version from another account?
http://marmalade-repo.org/packages/sourcetalk

@malroc

This comment has been minimized.

Copy link

commented Oct 2, 2014

Hi Nic, could you please remove the old version of my package so I could upload a new one? http://marmalade-repo.org/packages/sourcetalk

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 8, 2014

Yes. Sorry, I've got a bunch of marmalade admin piling up. I will get to it this week hopefully.

@malroc

This comment has been minimized.

Copy link

commented Oct 12, 2014

NP. Any updates?

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 17, 2014

Really sorry. I am adding the user create right now... just testing it. As soon as I'm done I'll send you a reg.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

@rolandwalker @ArneBab I'm really sorry I've been totally unable to reclaim that stuff... it just takes too much time.

If I make you new users will you please upload again? I'll send you a new user email anyway.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

@rolandwalker sorry, I forgot that yours is just an assignment problem.

Can you confirm that these are your packages:

  • alert
  • buffer-utils
  • wiki-nav
  • syntactic-sugar
  • express
  • osx-browse
  • minimal-session-saver
  • simpleclip
  • nary file ./expand-region
  • ucs-utils
  • string-utils
  • unicode-progress-reporter
  • window-end-visible
  • unicode-whitespace
  • font-utils
  • unicode-fonts
  • ignoramus
  • anaphora
  • truthy
  • fixmee
  • vector-utils
  • button-lock
  • flyspell-lazy
  • dynamic-fonts
  • ido-load-library
  • hardhat
  • persistent-soft
  • back-button
  • unicode-enbox
  • browse-url-dwim
  • hippie-namespace
  • nav-flash
  • list-utils

if so I will just reassign ownership

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

@ArneBab yours are:

  • wisp
  • wisp-mode
  • cups
  • kanban

please confirm?

I now have user creation and package deletion and I'm right now adding package add owner so I am going to use you guys to test all that.

@rolandwalker

This comment has been minimized.

Copy link

commented Oct 18, 2014

@nicferrier Thanks!

Yes, those are mine, and your list is complete, with the following amendments:

  • "alert" was superseded by "express", because there is already a package named "alert" by another author
  • "nary file ./expand-region" looks like a copy-paste glitch
@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

oh yeah. There was a binary file :-)

I'll hand over alert anyway... then you can delete it if you want.

@nicferrier

This comment has been minimized.

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

@ArneBab yours are done too.

@nicferrier nicferrier closed this Oct 18, 2014

@nicferrier nicferrier reopened this Oct 18, 2014

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 18, 2014

@malroc do you have a username on marmalade? if you do and the user owns the package then you should be able to now delete it.

I am just preparing the documentation, but basically marmalade-upload (the package is now called marmalade-client ) now includes a marmalade-remove-package which will let you remove it.

@malroc

This comment has been minimized.

Copy link

commented Oct 19, 2014

@nicferrier as I said, it looks like I have 2 accounts, but I remember the credentials only for 1: oleg.kalistratov The package is owned by another one, and I don't remember the credentials for it. So could you please delete it manually, so I could upload a new version from the active account?

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 19, 2014

Or I can just assign ownership. Tell me which account you want it transferred to?

@malroc

This comment has been minimized.

Copy link

commented Oct 19, 2014

Sure, that would be great. My active account: http://marmalade-repo.org/profile/oleg.kalistratov/

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Oct 19, 2014

Done. You should be able to upload it now.

@malroc

This comment has been minimized.

Copy link

commented Oct 20, 2014

Thanks, everything's fine now.

@nicferrier nicferrier closed this Oct 20, 2014

@ArneBab

This comment has been minimized.

Copy link
Author

commented Nov 2, 2014

@nicferrier yes, wisp, wisp-mode, cups and kanban are my packages. Thank you! (and sorry for answering late - hectic times).

@ArneBab

This comment has been minimized.

Copy link
Author

commented Nov 18, 2014

I now got to testing, and I still can’t upload wisp-mode or kanban (did not yet check the others):

@nicferrier nicferrier reopened this Nov 19, 2014

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Nov 19, 2014

Ok. That's a bit odd because I am pretty sure I did these at the time. Try it now though and let me know.

@ArneBab

This comment has been minimized.

Copy link
Author

commented Nov 26, 2014

It now works: I updated both kanban and wisp-mode without problems.

Thank you!

As a short feedback: It isn’t clear from the interface that uploading a package with the same version leads to a version-clash, and it would be nice to have an “upload new version”-button on the page for each package I maintain.

For the version-clash: Options to make this easier would be a sentence like “If you want to update a package, ensure that you increment the version” above or below the upload field or an explicit information on the error page: “If you want to update this package, you must change the version.”

@nicferrier

This comment has been minimized.

Copy link
Owner

commented Nov 26, 2014

you could easily send me a PR to that effect, no? just to stop my lazy arse (which is currently getting up at 5AM every morning and not getting home till 9pm in the evening) from not doing it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.