error in process filter: Can't find suitable coding-system #3

Closed
ghost opened this Issue Apr 4, 2012 · 1 comment

Comments

Projects
None yet
1 participant
@ghost

ghost commented Apr 4, 2012

Hello

I had a problem starting chicken-slime. It gave me the following error:

Connecting to Swank on port 4005..
error in process filter: or: Can't find suitable coding-system
error in process filter: Can't find suitable coding-system

This issue has already been reported in: https://bugs.launchpad.net/slime/+bug/915207

I modified "swank-chicken.scm" as was suggested there:

"The last solution I found to work was the addition of two lines of code to swank-mit-scheme.scm, without having to make the previous modifications I described.
(define :coding-system "utf-8-unix")
...:encoding (:coding-systems ("utf-8-unix"))...
The updated code is attached."

But there was still an error after that regarding the wrong number of arguments for "swank:create-repl" which i had to modify to (create-repl _ _ _).

Now chicken-slime starts and seems to be working correctly.

Please take a look into this issue and patch it accordingly.

Thank you
Matus

@nickg

This comment has been minimized.

Show comment
Hide comment
@nickg

nickg Apr 8, 2012

Owner

Thanks for reporting this. Should be fixed by 7db8cc9 and b8eaa90.

Owner

nickg commented Apr 8, 2012

Thanks for reporting this. Should be fixed by 7db8cc9 and b8eaa90.

@nickg nickg closed this Apr 8, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment