Skip to content
This repository has been archived by the owner. It is now read-only.

No matching distribution found for aiohttp>=3.0.0 #395

Open
codingsett opened this issue Jun 2, 2018 · 27 comments

Comments

Projects
None yet
@codingsett
Copy link

commented Jun 2, 2018

Hello i was installing telepot on my ubuntu 16 server using python3.5 and i got the following error.What could be the issue?

@nickoala

This comment has been minimized.

Copy link
Owner

commented Jun 9, 2018

Aiohttp is currently at 3.0.1 and it did have 3.0.0. So I am not sure why your pip or pip3 cannot find it. Maybe you can try pip install aiohttp or pip3 install aiohttp to see what it says.

@mzfr

This comment has been minimized.

Copy link

commented Jun 10, 2018

@nickoala I am having the same issue. I tried installing it using both pip and pipenv and with both I am having the same issue.
When I do pip install telepot or pip3 install telepot I am getting:

Collecting aiohttp>=3.0.0 (from telepot)
  Could not find a version that satisfies the requirement aiohttp>=3.0.0 (from telepot) (from versions: 0.1, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.14.4, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.16.4, 0.16.5, 0.16.6, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.20.0, 0.20.1, 0.20.2, 0.21.0, 0.21.1, 0.21.2, 0.21.4, 0.21.5, 0.21.6, 0.22.0a0, 0.22.0b0, 0.22.0b1, 0.22.0b2, 0.22.0b3, 0.22.0b4, 0.22.0b5, 0.22.0b6, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 2.0.0rc1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.6.post1, 2.0.7, 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3.0a1, 2.3.0a2, 2.3.0a4, 2.3.0, 2.3.1a1, 2.3.1, 2.3.2b2, 2.3.2b3, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.10, 3.0.0b0)
No matching distribution found for aiohttp>=3.0.0 (from telepot)

Building it with source like python3 setup.py install doesn't leads to any error.

@nickoala

This comment has been minimized.

Copy link
Owner

commented Jun 13, 2018

I have tried these on Raspbian Stretch and Ubuntu 16.04:

sudo pip3 install aiohttp==3.0.0
sudo pip3 install --upgrade aiohttp

Both commands work fine on both platforms, the first giving me 3.0.0, the second 3.3.2.

The only thing I can think of may be different on your machines is the URL of the package index from which pip looks for packages. By default, it should be PYPI, and PYPI does have aiohttp>=3.0.0. On some machines, there may be a file, e.g. /etc/pip.conf, specifying another URL to look for packages.

Other than that, I really can't think of anything else ...

@mzfr

This comment has been minimized.

Copy link

commented Jun 13, 2018

@nickoala Yes I can install them manually by those commands you mentioned but after than that whenever I do pip install telepot the build process stops on the aiohttp>=3.0.0.

Also for some reason building it from source doesn't lead to any errors

@codingsett

This comment has been minimized.

Copy link
Author

commented Jun 18, 2018

pip install now works tested on python3.5 seems maybe something was wrong with pypi so @mzfr you can try and see if it works for you now

@codingsett codingsett closed this Jun 18, 2018

@mzfr

This comment has been minimized.

Copy link

commented Jun 18, 2018

@codingsett No it doesn't work. I am still getting the same error. I even cleared the cache for pip even then I am getting the same error

@p3lli

This comment has been minimized.

Copy link

commented Jul 1, 2018

Hi,
I'm having the same problem installing telepot in a python3.5 virtualenv

(env3) pip3 install -r requirements3.txt
Collecting telepot (from -r requirements3.txt (line 1))
  Cache entry deserialization failed, entry ignored
Collecting urllib3>=1.9.1 (from telepot->-r requirements3.txt (line 1))
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/bd/c9/6fdd990019071a4a32a5e7cb78a1d92c53851ef4f56f62a3486e6a7d8ffb/urllib3-1.23-py2.py3-none-any.whl
Collecting aiohttp>=3.0.0 (from telepot->-r requirements3.txt (line 1))
  Could not find a version that satisfies the requirement aiohttp>=3.0.0 (from telepot->-r requirements3.txt (line 1)) (from versions: 0.1, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.14.4, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.16.4, 0.16.5, 0.16.6, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.20.0, 0.20.1, 0.20.2, 0.21.0, 0.21.1, 0.21.2, 0.21.4, 0.21.5, 0.21.6, 0.22.0a0, 0.22.0b0, 0.22.0b1, 0.22.0b2, 0.22.0b3, 0.22.0b4, 0.22.0b5, 0.22.0b6, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 2.0.0rc1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.6.post1, 2.0.7, 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3.0a1, 2.3.0a2, 2.3.0a4, 2.3.0, 2.3.1a1, 2.3.1, 2.3.2b2, 2.3.2b3, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.10, 3.0.0b0)
No matching distribution found for aiohttp>=3.0.0 (from telepot->-r requirements3.txt (line 1))

At the moment, requirements3.txt file only contains telepot

@p3lli

This comment has been minimized.

Copy link

commented Jul 1, 2018

Also (env3) pip3 install aiohttp==3.0.0 gave me this output:

Collecting aiohttp==3.0.0
  Could not find a version that satisfies the requirement aiohttp==3.0.0 (from versions: 0.1, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.14.4, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.16.4, 0.16.5, 0.16.6, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.20.0, 0.20.1, 0.20.2, 0.21.0, 0.21.1, 0.21.2, 0.21.4, 0.21.5, 0.21.6, 0.22.0a0, 0.22.0b0, 0.22.0b1, 0.22.0b2, 0.22.0b3, 0.22.0b4, 0.22.0b5, 0.22.0b6, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 2.0.0rc1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.6.post1, 2.0.7, 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3.0a1, 2.3.0a2, 2.3.0a4, 2.3.0, 2.3.1a1, 2.3.1, 2.3.2b2, 2.3.2b3, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.10, 3.0.0b0)
No matching distribution found for aiohttp==3.0.0
@mssalnikov

This comment has been minimized.

Copy link

commented Jul 3, 2018

Same issue here, Ubuntu 16.04, max aiohttp version in python3.5 virtualenv is 3.0.0b0

@onkelandy

This comment has been minimized.

Copy link

commented Jul 10, 2018

Same issue with Debian stretch and Python 3.5.2 :(
Pip3 version is 10.0.1

@codingsett codingsett reopened this Jul 10, 2018

@codingsett

This comment has been minimized.

Copy link
Author

commented Jul 10, 2018

Reopened the issue because many people seem to have problems with the installation of the updated package maybe somebody might find a lasting solution to this ...

@ritiek

This comment has been minimized.

Copy link

commented Jul 28, 2018

To add - pip3 install telepot works fine on my Linux Mint 19 and on my Raspbian Stretch.

Collecting aiohttp>=3.0.0 (from telepot)
  Downloading https://files.pythonhosted.org/packages/72/6a/5bbf3544fe8de525f4521506b372dc9c3b13070fe34e911c976aa95631d7/aiohttp-3.3.2.tar.gz (771kB)
    100% |████████████████████████████████| 778kB 144kB/s 
@deckar01

This comment has been minimized.

Copy link

commented Jul 31, 2018

I had the same issue. The latest version available was 2.3.2b2. I was using pip 9.0.1 provided by the ubuntu repo. Upgrading pip seems to have resolved the issue.

python -m pip install --upgrade pip
@The-Judge

This comment has been minimized.

Copy link

commented Aug 3, 2018

Linux Mint 18.3 does not work with latest pip:

telegrambot $ pip -V
pip 18.0 from /home/mrichter/.virtualenvs/telegrambot/lib/python3.5/site-packages/pip (python 3.5)
telegrambot $ pip install telepot
Collecting telepot
  Using cached https://files.pythonhosted.org/packages/f6/a8/0ed945afd8064b850c1653816c16ebda1cf07d65fee228b6d1139a49cbbd/telepot-12.7.tar.gz
Collecting urllib3>=1.9.1 (from telepot)
  Using cached https://files.pythonhosted.org/packages/bd/c9/6fdd990019071a4a32a5e7cb78a1d92c53851ef4f56f62a3486e6a7d8ffb/urllib3-1.23-py2.py3-none-any.whl
Collecting aiohttp>=3.0.0 (from telepot)
  Could not find a version that satisfies the requirement aiohttp>=3.0.0 (from telepot) (from versions: 0.1, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.14.4, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.16.4, 0.16.5, 0.16.6, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.20.0, 0.20.1, 0.20.2, 0.21.0, 0.21.1, 0.21.2, 0.21.4, 0.21.5, 0.21.6, 0.22.0a0, 0.22.0b0, 0.22.0b1, 0.22.0b2, 0.22.0b3, 0.22.0b4, 0.22.0b5, 0.22.0b6, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 2.0.0rc1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.6.post1, 2.0.7, 2.1.0, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3.0a1, 2.3.0a2, 2.3.0a4, 2.3.0, 2.3.1a1, 2.3.1, 2.3.2b2, 2.3.2b3, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.10, 3.0.0b0)
No matching distribution found for aiohttp>=3.0.0 (from telepot)
telegrambot $

PS: This is happening with the Python from python3.5 package only. If I'm using self-compiled Python 3.6.5, everything is fine.

@deckar01

This comment has been minimized.

Copy link

commented Aug 6, 2018

pip 10.0.1 that was installed with python3.7 on a mac using brew finds the new versions of aiohttp fine. Maybe a problem with the ubuntu/mint pip packages?

@The-Judge

This comment has been minimized.

Copy link

commented Aug 6, 2018

There is no such thing as OS dependent pip packages if pip is used.

@deckar01

This comment has been minimized.

Copy link

commented Aug 6, 2018

I am referring to prebuilt pip packages distributed by official distro repositories. Those packages do not install from source, so the build may be affected by the publisher's operating system. Building from source and installing the same pip versions from non ubuntu/mint repos seem to work fine.

https://packages.ubuntu.com/trusty/python3-pip

@Firdauzfan

This comment has been minimized.

Copy link

commented Aug 7, 2018

upgrade python to python 3.6...

@BassApps

This comment has been minimized.

Copy link

commented Aug 19, 2018

Same issue here, macOS
EDIT: The comment from @Firdauzfan helped me. I've overridden my system-wide python3.5 installation with 3.7 now, probably messing up a lot of other stuff on my mac because I couldn't be bothered to invest even more time into finding out how to link pip3 to the python3.7 installation but yea, @Firdauzfan was right
And I hate python, just saying

@damiska

This comment has been minimized.

Copy link

commented Aug 22, 2018

Проверьте свою версию Python, а далее прочтите это - https://aiohttp.readthedocs.io/en/stable/faq.html #id5
update url

@sbassi

This comment has been minimized.

Copy link

commented Nov 10, 2018

Same problem here, I can pip install aiohttp in macOS but not on Ubuntu 16.04.
See this log:
https://gist.github.com/sbassi/5f4d96a735ff276542a2246fe8673636

@4vadim4

This comment has been minimized.

Copy link

commented Nov 22, 2018

in my case ( macOS , python==3.5.2 ) i had an error:

"Could not find a version that satisfies the requirement aiohttp==3.3.2
bla-bla-bla
No matching distribution found for aiohttp==3.3.2"

but i updated both system and python (up to python 3.7.0) and now i have:

"Successfully installed aiohttp-3.4.4 async-timeout-3.0.1 attrs-18.2.0 chardet-3.0.4 idna-2.7 multidict-4.5.1 telepot-12.7 urllib3-1.24.1 yarl-1.2.6"

@sbassi

This comment has been minimized.

Copy link

commented Nov 24, 2018

yes, the problem is the Python version.

@hrchu

This comment has been minimized.

Copy link

commented Feb 23, 2019

problem exist in ubuntu 16.04

@leomrocha

This comment has been minimized.

Copy link

commented Mar 2, 2019

Problem still there in Ubuntu 16.04 and Python 3.5

@wrzadkow

This comment has been minimized.

Copy link

commented Mar 25, 2019

Problem still there in Ubuntu 16.04 and Python 3.5

Can confirm, exactly the same configuration, Python 3.5, Ubuntu Ubuntu 16.04.3 LTS and I'm experiencing the problem referenced.

@apogiatzis

This comment has been minimized.

Copy link

commented May 26, 2019

Updating python to 3.7.x worked for me!

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.